NetWorker Oracle Backups Fail with Lockbox Errors after nsrdr

Summary: The NetWorker Oracle Recovery Manager (RMAN) backups fail with a lockbox error, while NetWorker Client file system backups complete successfully.

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Symptoms

The NetWorker Oracle Recovery Manager (RMAN) backups fail with a lockbox error, while NetWorker Client file system backups complete successfully.

The NetWorker data zone encountered a failure and the NetWorker disaster recovery (nsrdr) procedure was performed prior to encountering the symptom.

The backup session log shows:
139170:nsrdavsc: Unable to obtain the user credentials from the lockbox due to the following error: "Failed to open lockbox /nsr/lockbox/myclient.mydomain.com/clb.lb"
Screenshot of error message

The NetWorker client configuration wizard for the affected NetWorker Oracle RMAN clients also fails with to create a new NetWorker Client instance:
Operation Failed: Failed to open lockbox /nsr/lockbox/myclient.mydomain.com/clb.lb
screenshot_2.jpg

Cause

The cause of the NetWorker server nsrdr not being able to access the NetWorker Oracle Client lockbox details is unknown.

Resolution

The following procedure can be used to re-create the NetWorker Client lockbox and resolve the Oracle backup lockbox failures. The example uses the example NetWorker client myclient.mydomain.com.
  1. Delete the lockbox directory for the client on the NetWorker Server: /nsr/lockbox/myclient.mydomain.com
  2. Delete the myclient.mydomain.com lockbox in the NetWorker Management Console (NMC) Under "Server > Lockboxes."
  3. Select Ok when the error indicates it is not able to find the lockbox file.
  4. Run the NetWorker client creation wizard to create a new lockbox with the Oracle credentials.
  5. Validate the new lockbox was created in the NMC and /nsr/lockbox directory.
  6. Run the workflow that contains the original NetWorker Oracle RMAN Client entry and it uses the new lockbox information.
  7. The temporary NetWorker Client entry from step 4 can be deleted.
Article Properties
Article Number: 000189377
Article Type: Solution
Last Modified: 13 Aug 2025
Version:  2
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