NetWorker : La restauration redirigée (initiée à partir de NMC) a échoué alors que le client source est hors ligne

Summary: Une restauration NetWorker est tentée pour un client NetWorker qui est hors ligne et ne peut pas être mis sous tension. Le client a également été supprimé de la base de données des ressources NetWorker. Toutefois, il dispose toujours de sauvegardes valides. Le client a été rajouté à NetWorker pour restaurer ses données sur un autre client. L’interface utilisateur de restauration ne permet pas d’aller plus loin et signale le message « Unknown client operating system ». Il peut également signaler des problèmes de connexion réseau, car le client source est hors ligne. ...

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Symptoms

  • Une restauration redirigée est en cours d’exécution à partir de NetWorker Management Console (NMC) pour restaurer les fichiers d’un client (source) vers un autre client (destination).
  • Le client source est hors ligne et ne peut pas être mis sous tension ; ou n’existe plus physiquement.
  • Le client a été supprimé de NetWorker, mais il dispose toujours de sauvegardes dans la base de données des supports du serveur NetWorker. Les savesets requis ont été identifiés à l’aide de la fonction NMC Media-Save> Sets ou de la commande mminfo du serveur NetWorker :
mminfo -avot -q client=CLIENT_NAME
  • Le client source supprimé a été ajouté à nouveau à NetWorker afin que ses savesets soient récupérés dans l’interface utilisateur de restauration.
  • Lorsque vous tentez d’extraire des sauvegardes à partir du client source hors ligne, les erreurs suivantes s’affichent dans NMC :
    • Aucune information sur le système d’exploitation ne s’affiche lors de la sélection du client source.
    • Error: Le délai d’attente du répartiteur a expiré.
    • Error: Échec de la connexion à l’hôte source-client-name : Répartiteur: La demande a expiré.
    • Système d’exploitation client inconnu.
  • Le bouton Suivant n’est pas disponible.
Erreur de système d’exploitation client inconnu dans NMC
Figure 1 : Erreur « Unknown client operating system » observée dans l’assistant de restauration de NetWorker Management Console.

Cause

Lors de l’exécution d’une restauration, l’assistant de restauration vérifie que les systèmes d’exploitation source et cible sont du même type. Par exemple : « Windows NT Server on Intel » ou « Linux ». Lorsque le client a été rajouté à NetWorker, l’option « New Client Properties » a été utilisée, car l’hôte client est hors ligne. Il n’y a pas de connexion entre le serveur et le client, de sorte qu’il ne peut pas mettre à jour le « type de système d’exploitation client »

Resolution

Option 1 :

Effectuez la restauration à partir de la ligne de commande. Pour plus d’informations sur l’utilisation de la commande recover , reportez-vous au NetWorker Command Reference Guide : https://www.dell.com/support/home/product-support/product/networker/docs


Option 2 :

1. Ouvrez les propriétés du client à partir de NetWorker Management Console (NMC).
Remarque : Si le client hors ligne n’existe pas dans NetWorker Server, mais qu’il dispose de sauvegardes sur le NetWorker Server, ajoutez-le de nouveau à l’aide de l’option « New Client Properties ».


2. Assurez-vous que le client ne se trouve dans aucun groupe de protection. Si des groupes de protection sont sélectionnés, effacez-les :

Sélection de la liste des groupes de protection dans l’onglet Propriétés du client Général
Figure 2 : Sélectionnez « Protection group list » dans l’onglet général des propriétés du client.

3. Dans l’onglet Globals (2 sur 2), sélectionnez la liste déroulante client state, puis sélectionnez retired :

Liste déroulante Client State dans les propriétés du client Onglet Globals (2 sur 2)
Figure 3 : Liste déroulante « Client state » dans l’onglet Globals (2 sur 2) des propriétés du client.

4. Ouvrez une invite PowerShell d’administrateur ou un shell racine sur le NetWorker Server. Utilisez nsradmin en mode hors ligne pour mettre à jour le type de système d’exploitation client. Il s’agit d’un champ en lecture seule qui ne peut être modifié qu’en mode hors ligne. Un redémarrage du service est nécessaire pour que la modification s’applique.

nsrdb default location :

Linux : /nsr/res/nsrdb
Windows : C :\Program Files\EMC NetWorker\nsr\res\nsrdb

A. Créez une copie de nsrdb dans le répertoire /tmp :

Linux : 

cp -Rv /nsr/res/nsrdb /tmp/nsrdb_`date -I`

Windows : Utilisez l’explorateur de fichiers Windows pour créer une copie de l’option nsrdb
PowerShell :

PS C:\Users\Administrator> $date = Get-Date -Format yyyMMdd
PS C:\Users\Administrator> Copy-Item -Path "C:\Program Files\EMC NetWorker\nsr\res\nsrdb" -Destination "C:\tmp\nsrdb_$date" -Recurse -Verbose

B. Saisissez :

nsradmin -d "PATH_TO_NSRDB"

C. Saisissez :

option hidden

D. Saisissez :

. type: nsr client; name: client-name

E. Saisissez :

update client os type: OS-TYPE
Remarque : Pour les systèmes d’exploitation Windows, définissez OS-TYPE sur « Windows NT Server on Intel ». Pour les systèmes Linux, définissez OS-TYPE sur « Linux »  
root@lnx-nwserv:~# nsradmin -d /nsr/res/nsrdb
NetWorker administration program.
Use the "help" command for help, "visual" for full-screen mode.
nsradmin> option hidden
Hidden display option turned on

Display options:
        Dynamic: Off;
        Hidden: On;
        Raw I18N: Off;
        Resource ID: Off;
        Regexp: Off;
nsradmin> . type: nsr client; name: win-client01.amer.lan
nsradmin> update client OS type: Windows NT Server on Intel
              client OS type: Windows NT Server on Intel;
Update? y
updated resource id 53.0.166.57.0.0.0.0.233.98.62.102.192.168.9.101(3)
nsradmin> q

F. Redémarrez les services NetWorker sur le NetWorker Server. 

AVERTISSEMENT : Le redémarrage des services NetWorker annule toutes les tâches de sauvegarde, de clonage ou de restauration en cours. N’effectuez cette étape que si aucune tâche n’est en cours d’exécution ou s’il est acceptable que les tâches en cours d’exécution soient interrompues.

Linux :

systemctl restart networker

Windows (PowerShell) :

net stop nsrd ; net start nsrd
Remarque : Si des problèmes de démarrage de service sont observés. Arrêtez les services NetWorker, renommez le \nsr\res\nsrdb, remplacez la copie créée à l’étape 4A à sa place, puis redémarrez les services. Reportez-vous plutôt à l’option 1 pour effectuer une restauration par ligne de commande.


5. Connectez-vous au NetWorker Server à partir de NMC et ouvrez à nouveau les propriétés du client. Dans l’onglet Info et licences, le type de système d’exploitation client doit refléter les paramètres appliqués à l’étape 4 :

Type de système d’exploitation client affiché dans l’onglet Propriétés du client Info et Licences.
Figure 4 : « Client OS type » affiché dans l’onglet « Info & Licensing » des propriétés du client.

6. Relancez la restauration à partir de l’onglet Recover :

Le problème n’est plus affiché dans l’interface utilisateur de restauration
Figure 5 : L’option Suivant n’est plus disponible et l’erreur Système d’exploitation client inconnu a disparu. 

Affected Products

NetWorker Series
Article Properties
Article Number: 000203590
Article Type: Solution
Last Modified: 14 May 2024
Version:  3
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