VxRail: Node Health-check Fails for Test 'idc_swi' (iDRAC Software Inventory)
Summary: The "idc_swi" test queries that the Software Inventory can be read and returns the current iDRAC version.
This article applies to
This article does not apply to
This article is not tied to any specific product.
Not all product versions are identified in this article.
Symptoms
The health-check 'idc_swi' runs on ESXi nodes as part of the VxVerify health-checks and retrieves the software inventory from iDRAC. This ensures that ESXi to iDRAC communication is working correctly and the inventory is parsed for versions with known upgrade issues.
|
Test Result
|
Result code
|
Result Interpretation
|
|
Pass
|
0
|
Software inventory read for the current iDRAC version
|
|
Warning
|
1
|
Invalid response from iDRAC received.
|
| Failure | 2 | iDRAC queries failed or an issue was found that would block an upgrade. |
| Critical | 3 |
This test has no critical result.
|
Each test that passes is not listed in the summary report, for ease of reading.
An example of the health-check output, when the software inventory failed, is shown below:
#========================#======#=========#====================================================================#==============# | Hostname / Category |Status Dell_KB | Warnings or Failures, unless tests Passed ; Product S.N. | #========================#======#=========#====================================================================#==============# | node01 | Warning 205769 | idc_swi: iDRAC invalid response: ... .| | node02 | Failure 205769 | idc_swi: iDRAC 6.10.80.00 will cause upgrade from 70410 to fail .|
Cause
iDRAC tests only apply to Dell nodes and are bypassed for virtual and Quanta nodes.
This test queries that the Software Inventory can be read and returns the current iDRAC version, which can be seen in the vxtii.txt report.
This test queries that the Software Inventory can be read and returns the current iDRAC version, which can be seen in the vxtii.txt report.
Resolution
iDRAC not responding.
- Connect to the iDRAC UI and check if that is working and reporting correctly.
- Use racadm to check if the racadm swinventory command returns successfully.
- The following command can be run from the ESXi console (this does not work on VxRail 8.0.300 or above):
-
/opt/vxrail/bin/remotecmd -q -o StrictHostKeyChecking=no -o UserKnownHostsFile=/dev/null -o PubkeyAuthentication=yes -o PasswordAuthentication=no -i /etc/ssh/ssh_host_rsa_key -l vxpsvc 169.254.0.1 racadm swinventory
- If the command does not return correctly, reset or reboot the IDRAC.
- For example, to reboot the iDRAC using ipmitool see below command:
-
/opt/vxrail/tools/ipmitool mc reset cold
-
- (For further details, see VxRail KB article 528587: VxRail: How to use ipmitool)
- For example, to reboot the iDRAC using ipmitool see below command:
- After iDRAC is reset, test again and If racadm swinventory returns correctly, rerun VxVerify
Affected Products
VxRail Appliance SeriesProducts
VxRail, VxRail Appliance Family, VxRail SoftwareArticle Properties
Article Number: 000043137
Article Type: Solution
Last Modified: 04 Jul 2025
Version: 7
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.