PowerStore: SRA "Nepodařilo se povýšit replikovaná zařízení. Příkaz SRA "failover" selhal. Obecná chyba --> podrobnosti naleznete v protokolech.

Summary: SRA nedokáže povýšit zařízení repliky s obecnou chybou.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Nelze provést převzetí služeb při selhání pomocí nástroje SRM/SRA Může se zobrazit zpráva SRA
Command failover failed nebo "Failed to promote replica devices. Příkaz SRA "failover" selhal. obecná chyba –> check logs for details" v grafickém uživatelském rozhraní vCenter při pokusu o převzetí služeb při selhání nebo testovacím převzetí služeb při selhání. 
V protokolech SRM/SRA je vyhledejte a rozbalte je. Přejděte do nabídky Logs > SRA/SRAs/SHA256xxxx (může být nutné zkontrolovat každý z nich, abyste v protokolech našli nejnovější datum)Nejprve zkontrolujte protokol označený vmware-dr.log, zda neobsahuje následující řádek, a ověřte,
že se v rozhraní příkazového řádku a grafickém uživatelském rozhraní zobrazuje stejná chyba:
-->          (dr.storageProvider.fault.StorageFailoverFailed) {
-->             faultCause = (dr.storage.fault.CommandFailed) {
-->                faultCause = (dr.storage.fault.LocalizableAdapterFault) {
-->                   faultCause = (vmodl.MethodFault) null, 
-->                   faultMessage = <unset>, 
-->                   code = "70c18a97-02e4-4523-b9c5-c222ebdedaff.501", 
-->                   arg = <unset>
-->                   msg = "general error
--> check logs for details"
-->                }, 
-->                faultMessage = <unset>, 
-->                commandName = "failover"
-->                msg = "SRA command 'failover' failed. general error
--> check logs for details"
-->             }, 
-->             faultMessage = <unset>
-->             msg = "Failed to promote replica devices. SRA command 'failover' failed. general error
--> check logs for details"
Dále zkontrolujte, zda FAILOVER.log následující:
[error] 2024-01-22 17:56:04,177 sra_logger.py:log_call_without_args:137: function get_storage_ports failed with error: "'NoneType' object has no attribute 'name'" <--- this line
[verbose] 2024-01-22 17:56:04,178 failover.py:get_result:382: Complete method 'get_storage_ports'
[error] 2024-01-22 17:56:04,178 executor.py:start:133: 'NoneType' object has no attribute 'name'  <----- this line

[error] 2024-01-22 17:56:04,181 executor.py:start:139: SRM result in dict - b"{'response': {'error': {'@code': 501}}}"
[info] 2024-01-22 17:56:04,182 executor.py:safety_print:42: output XML:
<?xml version="1.0" encoding="utf-8"?>
<Response xmlns="http://www.vmware.com/srm/sra/v2" xmlns:custom="http://www.dellemc/srm/sra/custom/v1">
	<Error code="501"/>
</Response>

Cause

PowerStore ve verzi 3.5.0.x SRA ve verzi

2.1.0.190Ve verzi 2.1.0.190 došlo k chybě SRA, kdy jakékoli informace zadané do seznamu "Preferred Remote PowerStore Manager IPS Allowed" způsobují, že SRA NEMŮŽE najít objekt.

Resolution

Alternativní řešení:
Odeberte veškeré informace ze seznamu "Preferred Remote PowerStore Manager IP Allowed" a zkuste to znovu. 
Oprava:
Oprava je k dispozici ve verzi SRA 2.1.1

Additional Information


https://dl.dell.com/content/manual39134286-dell-technologies-powerstore-sra-plugin-for-vmware-site-recovery-manager-release-note.pdf?language=en-usStránka 4 – Opraveny problémy, kdy
nefungovalo plánované převzetí služeb při selhání SRM s ABR. Plánované převzetí služeb při selhání SRM nefunguje, pokud je povoleno volitelné upřednostňované
nastavení IP adres zařízení PowerStore.

Affected Products

PowerStore 1200T, PowerStore 3000X, PowerStore 3000T, PowerStore 3200T, PowerStore 5000X, PowerStore 5000T, PowerStore 500T, PowerStore 5200T, PowerStore 7000X, PowerStore 7000T

Products

PowerStore 9000X, PowerStore 9000T, PowerStore 9200T
Article Properties
Article Number: 000221365
Article Type: Solution
Last Modified: 08 Oct 2025
Version:  3
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.