PowerStore. SRA «Не удалось повысить реплики устройств. Сбой команды SRA «failover». Общая ошибка --> проверьте журналы для получения подробной информации"

Summary: SRA не удается повысить реплику устройства с общей ошибкой.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Не удается выполнить переключение на резервный ресурс с помощью SRM/SRA Может отобразиться сбой переключения команды SRA
на резервный ресурс или «Не удалось повысить устройства репликации. Сбой команды SRA «failover». Общая ошибка —> проверьте журналы для получения подробной информации» в графическом интерфейсе пользователя vCenter при попытке переключения при отказе или тестового переключения при отказе. 
В SRM/SRA журналы перейдите к ним, а затем распакуйте их. Перейдите в раздел Logs SRAs/ SRAs>/ SHA256xxxx (возможно, потребуется проверить каждый из них, чтобы найти последнюю дату в журналах)
Сначала проверьте журнал с меткой vmware-dr.log следующую строку, чтобы убедиться, что CLI и графический интерфейс пользователя отображают одну и ту же ошибку:
-->          (dr.storageProvider.fault.StorageFailoverFailed) {
-->             faultCause = (dr.storage.fault.CommandFailed) {
-->                faultCause = (dr.storage.fault.LocalizableAdapterFault) {
-->                   faultCause = (vmodl.MethodFault) null, 
-->                   faultMessage = <unset>, 
-->                   code = "70c18a97-02e4-4523-b9c5-c222ebdedaff.501", 
-->                   arg = <unset>
-->                   msg = "general error
--> check logs for details"
-->                }, 
-->                faultMessage = <unset>, 
-->                commandName = "failover"
-->                msg = "SRA command 'failover' failed. general error
--> check logs for details"
-->             }, 
-->             faultMessage = <unset>
-->             msg = "Failed to promote replica devices. SRA command 'failover' failed. general error
--> check logs for details"
Затем проверьте FAILOVER.log на следующее:
[error] 2024-01-22 17:56:04,177 sra_logger.py:log_call_without_args:137: function get_storage_ports failed with error: "'NoneType' object has no attribute 'name'" <--- this line
[verbose] 2024-01-22 17:56:04,178 failover.py:get_result:382: Complete method 'get_storage_ports'
[error] 2024-01-22 17:56:04,178 executor.py:start:133: 'NoneType' object has no attribute 'name'  <----- this line

[error] 2024-01-22 17:56:04,181 executor.py:start:139: SRM result in dict - b"{'response': {'error': {'@code': 501}}}"
[info] 2024-01-22 17:56:04,182 executor.py:safety_print:42: output XML:
<?xml version="1.0" encoding="utf-8"?>
<Response xmlns="http://www.vmware.com/srm/sra/v2" xmlns:custom="http://www.dellemc/srm/sra/custom/v1">
	<Error code="501"/>
</Response>

Cause

PowerStore на версии 3.5.0.x, SRA на версии
2.1.0.190.
В SRA 2.1.0.190 имеется ошибка, из-за которой любая информация, помещенная в список разрешенных предпочтительных удаленных IP-адресов PowerStore Manager, приводит к тому, что SRA НЕ может найти объект.

Resolution

Временное решение.Удалите всю информацию из списка разрешенных предпочтительных удаленных IP-адресов PowerStore Manager и повторите попытку.
 
Исправление:
Исправление доступно в SRA версии 2.1.1

Additional Information


https://dl.dell.com/content/manual39134286-dell-technologies-powerstore-sra-plugin-for-vmware-site-recovery-manager-release-note.pdf?language=en-usСтраница 4 — устранены неполадки, из-за которых
не работало запланированное переключение SRM на резервный ресурс с ABR. Запланированное переключение SRM на резервный ресурс не работает, если для параметра предпочтительных
IP-адресов PowerStore разрешено значение Необязательно.

Affected Products

PowerStore 1200T, PowerStore 3000X, PowerStore 3000T, PowerStore 3200T, PowerStore 5000X, PowerStore 5000T, PowerStore 500T, PowerStore 5200T, PowerStore 7000X, PowerStore 7000T

Products

PowerStore 9000X, PowerStore 9000T, PowerStore 9200T
Article Properties
Article Number: 000221365
Article Type: Solution
Last Modified: 08 Oct 2025
Version:  3
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.