PowerStore: SRA "Impossibile promuovere i dispositivi di replica. 'failover' del comando SRA non riuscito. Errore generale --> controllare i registri per i dettagli"

Summary: SRA non riesce a promuovere il dispositivo di replica con errore generico.

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Symptoms

Impossibile eseguire il failover utilizzando SRM/SRA È possibile che venga visualizzato il messaggio SRA
command failover failed o "Failed to promote replica devices. 'failover' del comando SRA non riuscito. errore generale --> controllare i registri per i dettagli" nella GUI di vCenter quando si tenta un failover o un failover di test. 
Nei registri SRM/SRA, individuarli e decomprimerli. Passare a Logs SRAs/SRAs>/ SHA256xxxx (potrebbe essere necessario controllare ognuno di essi per trovare la data più recente nei registri)
Per prima cosa, controllare il registro con l'etichetta vmware-dr.log per la riga seguente per verificare che CLI e GUI visualizzino lo stesso errore:
-->          (dr.storageProvider.fault.StorageFailoverFailed) {
-->             faultCause = (dr.storage.fault.CommandFailed) {
-->                faultCause = (dr.storage.fault.LocalizableAdapterFault) {
-->                   faultCause = (vmodl.MethodFault) null, 
-->                   faultMessage = <unset>, 
-->                   code = "70c18a97-02e4-4523-b9c5-c222ebdedaff.501", 
-->                   arg = <unset>
-->                   msg = "general error
--> check logs for details"
-->                }, 
-->                faultMessage = <unset>, 
-->                commandName = "failover"
-->                msg = "SRA command 'failover' failed. general error
--> check logs for details"
-->             }, 
-->             faultMessage = <unset>
-->             msg = "Failed to promote replica devices. SRA command 'failover' failed. general error
--> check logs for details"
Quindi controllare il FAILOVER.log per quanto segue:
[error] 2024-01-22 17:56:04,177 sra_logger.py:log_call_without_args:137: function get_storage_ports failed with error: "'NoneType' object has no attribute 'name'" <--- this line
[verbose] 2024-01-22 17:56:04,178 failover.py:get_result:382: Complete method 'get_storage_ports'
[error] 2024-01-22 17:56:04,178 executor.py:start:133: 'NoneType' object has no attribute 'name'  <----- this line

[error] 2024-01-22 17:56:04,181 executor.py:start:139: SRM result in dict - b"{'response': {'error': {'@code': 501}}}"
[info] 2024-01-22 17:56:04,182 executor.py:safety_print:42: output XML:
<?xml version="1.0" encoding="utf-8"?>
<Response xmlns="http://www.vmware.com/srm/sra/v2" xmlns:custom="http://www.dellemc/srm/sra/custom/v1">
	<Error code="501"/>
</Response>

Cause

PowerStore sulla versione 3.5.0.x SRA sulla versione
2.1.0.190.
Esiste un bug con SRA sulla versione 2.1.0.190 in cui qualsiasi informazione inserita nell'elenco "Preferred Remote PowerStore Manager IPs Allowed list" fa sì che SRA NON sia in grado di trovare un oggetto.

Resolution

Soluzione:
rimuovere eventuali informazioni nell'elenco "Preferred Remote PowerStore Manager IPs Allowed list" e riprovare. 
Correzione:
la correzione è disponibile in SRA versione 2.1.1

Additional Information


https://dl.dell.com/content/manual39134286-dell-technologies-powerstore-sra-plugin-for-vmware-site-recovery-manager-release-note.pdf?language=en-usPagina 4 - Risolti i problemi
relativi al failover pianificato di SRM con ABR non funzionante. Un failover SRM pianificato non funziona quando è consentita l'impostazione degli IP PowerStore preferiti
Opzionale.

Affected Products

PowerStore 1200T, PowerStore 3000X, PowerStore 3000T, PowerStore 3200T, PowerStore 5000X, PowerStore 5000T, PowerStore 500T, PowerStore 5200T, PowerStore 7000X, PowerStore 7000T

Products

PowerStore 9000X, PowerStore 9000T, PowerStore 9200T
Article Properties
Article Number: 000221365
Article Type: Solution
Last Modified: 08 Oct 2025
Version:  3
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