Data Domain - Setting and Verifying the Correct Admin Email
Summary: Unable to receive Autosupport alert emails from the Data Domain device internally and externally.
Symptoms
Autosupport alert emails are not received from the Data Domain device internally and externally.
This article provides instructions on how to configure the admin email address to allow it to be relayed and received externally by Data Domain support.
Cause
The admin-email is used as the sender address for autosupport and alert emails to other recipients. It will be seen in the from section of the autosupport email. An incorrect admin-email address causes alert messages to be reported as SPAM on the mail relay. If the MX record of the admin-email is incorrect it can also not be recognized externally.
Resolution
Verify the admin email address is correct:
# config show admin-email
If blank, set the admin email address by issuing:
# config set admin-email <email_address>
If the admin email is correct and forwarding is enabled on the local mail server (Data Domain - Alert emails from the Data Domain device are not sent to external email addresses) for the Data Domain System it may be that the admin email address does not have a valid MX record available to the outside world.
On Windows systems:
Verify the MX record in command line:
> nslookup
> set type=mx
Type the domain name you need the MX record for:
e.g.:- > domain.com
On Linux systems:
Verify the MX record by typing the following:
# dig t mx <domain>
If the mx lookup does not pull any results then it is not a public facing domain address and the admin email will need to be changed to one that is on a public facing domain.