NMC: La pestaña Hosts arroja un error: No se puede conectar al demonio de inserción de cliente

Summary: Cuando se selecciona la pestaña Hosts en la consola de administración de NetWorker, se tarda mucho tiempo en cargarse y, finalmente, se agota el tiempo de espera con el error: No se puede conectar al demonio de inserción de clientes ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Reiniciar los servicios hará que todos los demonios reciban nuevos puertos asignados dinámicamente durante el inicio.
Los demonios que fallan y se regeneran también recibirán nuevas asignaciones.
 
La selección de la pestaña Hosts en La consola de administración de NetWorker agota el tiempo de espera con el error:
No se puede conectar al demonio de inserción de clientes

Cause

El demonio de inserción del cliente nsrcpd se ejecuta en el servidor de NetWorker y tiene un puerto asignado dinámicamente desde el rango de puertos de servicio de NetWorker.
Si todos los puertos dentro del rango de puertos no están abiertos, un demonio asignado para escuchar en un puerto que no es accesible para los hosts remotos provocará una falla en la comunicación.

Resolution

  1. Intente acceder a la pestaña Hosts en NMC, la cual solicita al servidor de NetWorker que inicie el servicio nsrcpd .
  2. Confirme que nsrcpd se está ejecutando en el servidor de NetWorker y qué puerto TCP utiliza actualmente: nsrrpcinfo -p
nsrrpcinfo -p
PROGRAM VERSION PROTOCOL PORT SERVICE
...
...
390437  1       tcp      8766 nsrcpd         Client Push
  1. En el servidor de NMC, pruebe el acceso al puerto de escucha TCP asignado a nsrcpd en el servidor de NetWorker recopilado en el paso anterior:
    nsrports -t {networker_servername} -p {nsrcpd_portnum}
nsrports -t winsrvr2k12 -p 8766
Forward lookup for winsrvr2k12
Query time:              0.001 sec
Canonical name (CNAME):  winsrvr2k12.emclab.local
Address (A):             192.168.x.y
Connect to port 8766:    . . . . . . * Connection timed out

Reverse lookup for 192.168.x.y
Query time:              0.003 sec
Name:                    winsrvr2k12.emclab.local

  1. Si hay una falla de comunicación, confirme el rango de puertos de servicio configurado en el servidor de NetWorker mediante la ejecución local del comando nsrports. El rango predeterminado es 7937-9936. Confirme que no haya firewalls de software o hardware que bloqueen estos puertos entre el servidor NMC y el servidor networker.
nsrports -t winsrvr2k12 -p 8766
Forward lookup for winsrvr2k12
Query time:              0.001 sec
Canonical name (CNAME):  winsrvr2k12.emclab.local
Address (A):             192.168.25.3
Connect to port 8766:    Succeeded (0.000 sec)

Reverse lookup for 192.168.25.3
Query time:              0.000 sec
Name:                    winsrvr2k12.emclab.local
  1. Una vez que pueda conectarse a los puertos nsrcpd desde el servidor de NMC, debería poder acceder a la pestaña Hosts en NMC. Tenga en cuenta que otros tipos de software o configuración de seguridad también pueden ser capaces de interrumpir formas específicas de comunicación; en algunos casos, es posible que las pruebas básicas descritas no sean suficientes.

Affected Products

NetWorker

Products

NetWorker
Article Properties
Article Number: 000160392
Article Type: Solution
Last Modified: 09 Jun 2025
Version:  4
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.