NMC: La scheda Hosts restituisce l'errore - Unable to connect to Client Push daemon

Summary: Quando si seleziona la scheda Hosts in NetWorker Management Console, il caricamento richiede molto tempo e alla fine si verifica il timeout con l'errore: Impossibile connettersi al daemon client push ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Il riavvio dei servizi comporterà la ricezione di nuove porte assegnate dinamicamente all'avvio di tutti i daemon.
Anche i daemon che hanno esito negativo e vengono respawn riceveranno nuove assegnazioni.
 
Si verifica il timeout della scheda Hosts in NetWorker Management Console con l'errore:
Impossibile connettersi al daemon client push

Cause

Il daemon nsrcpd push del client viene eseguito sul server NetWorker e dispone di una porta assegnata dinamicamente dall'intervallo di porte del servizio NetWorker.
Se tutte le porte all'interno dell'intervallo di porte non sono aperte, un daemon assegnato per l'ascolto su una porta inaccessibile agli host remoti comporterà un errore di comunicazione.

Resolution

  1. Tentare di accedere alla scheda Hosts in NMC, che richiede al server NetWorker di avviare il servizio nsrcpd .
  2. Verificare che nsrcpd sia in esecuzione sul server NetWorker e quale porta TCP sta attualmente utilizzando: nsrrpcinfo -p
nsrrpcinfo -p
PROGRAM VERSION PROTOCOL PORT SERVICE
...
...
390437  1       tcp      8766 nsrcpd         Client Push
  1. Sul server NMC, testare l'accesso alla porta di ascolto TCP assegnata nsrcpd sul server NetWorker raccolto nel passaggio precedente:
    nsrports -t {networker_servername} -p {nsrcpd_portnum}
nsrports -t winsrvr2k12 -p 8766
Forward lookup for winsrvr2k12
Query time:              0.001 sec
Canonical name (CNAME):  winsrvr2k12.emclab.local
Address (A):             192.168.x.y
Connect to port 8766:    . . . . . . * Connection timed out

Reverse lookup for 192.168.x.y
Query time:              0.003 sec
Name:                    winsrvr2k12.emclab.local

  1. Se si verifica un errore di comunicazione, verificare l'intervallo delle porte di servizio configurato sul server NetWorker eseguendo il comando nsrportslocalmente. L'intervallo predefinito è 7937-9936. Verificare che non vi siano firewall software o hardware che blocchino queste porte tra il server NMC e il server NetWorker.
nsrports -t winsrvr2k12 -p 8766
Forward lookup for winsrvr2k12
Query time:              0.001 sec
Canonical name (CNAME):  winsrvr2k12.emclab.local
Address (A):             192.168.25.3
Connect to port 8766:    Succeeded (0.000 sec)

Reverse lookup for 192.168.25.3
Query time:              0.000 sec
Name:                    winsrvr2k12.emclab.local
  1. Una volta che si è in grado di connettersi alle porte nsrcpd dal server NMC, si dovrebbe essere in grado di accedere alla scheda Hosts in NMC. Si noti che altri tipi di software o impostazioni di sicurezza potrebbero anche essere in grado di interrompere specifiche forme di comunicazione; in alcuni casi, i test di base descritti potrebbero non essere sufficienti.

Affected Products

NetWorker

Products

NetWorker
Article Properties
Article Number: 000160392
Article Type: Solution
Last Modified: 09 Jun 2025
Version:  4
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.