NMC. На вкладке Hosts возвращается ошибка «Unable to connect to Client Push daemon»
Summary: При выборе вкладки Hosts в Консоли управления NetWorker загрузка занимает много времени и в конечном итоге происходит тайм-аут с ошибкой: Не удается подключиться к управляющей программы Client Push ...
This article applies to
This article does not apply to
This article is not tied to any specific product.
Not all product versions are identified in this article.
Symptoms
При перезапуске служб все управляющие программы получают новые динамически назначенные порты при запуске.
Управляющие программы, которые не выдержают и переустановите исправление, также получат новые назначения.
Управляющие программы, которые не выдержают и переустановите исправление, также получат новые назначения.
При выборе вкладки «Hosts » в консоли управления NetWorker время выполнения отображается с ошибкой:
Не удается подключиться к управляющей программы Client Push
Cause
Управляющая программа push клиента nsrcpd запускается на сервере NetWorker и имеет динамически назначенный порт из диапазона сервисных портов NetWorker.
Если все порты в диапазоне портов не открыты, управляющая программа, назначенная для прослушивания порта, который недоступен для удаленных хостов, приведет к сбою связи.
Если все порты в диапазоне портов не открыты, управляющая программа, назначенная для прослушивания порта, который недоступен для удаленных хостов, приведет к сбою связи.
Resolution
- Попытайтесь получить доступ к вкладке Hosts в NMC, чтобы предложить серверу NetWorker запустить службу nsrcpd .
- Убедитесь , что nsrcpd работает на сервере NetWorker и какой порт TCP в настоящее время использует: nsrrpcinfo -p
nsrrpcinfo -p
PROGRAM VERSION PROTOCOL PORT SERVICE
...
...
390437 1 tcp 8766 nsrcpd Client Push
- На сервере NMC проверьте доступ к назначенной TCP-порту прослушивания nsrcpd на сервере NetWorker, собранном на приведенном выше шаге:
nsrports -t {networker_servername} -p {nsrcpd_portnum}
nsrports -t winsrvr2k12 -p 8766
Forward lookup for winsrvr2k12
Query time: 0.001 sec
Canonical name (CNAME): winsrvr2k12.emclab.local
Address (A): 192.168.x.y
Connect to port 8766: . . . . . . * Connection timed out
Reverse lookup for 192.168.x.y
Query time: 0.003 sec
Name: winsrvr2k12.emclab.local
- В случае сбоя связи подтвердите диапазон сервисных портов, настроенный на сервере NetWorker, выполнив локальную команду nsrports. Диапазон по умолчанию: 7937-9936. Убедитесь в отсутствии программных или аппаратных брандмауэров, блокирующих эти порты между сервером NMC и сервером NetWorker.
nsrports -t winsrvr2k12 -p 8766
Forward lookup for winsrvr2k12
Query time: 0.001 sec
Canonical name (CNAME): winsrvr2k12.emclab.local
Address (A): 192.168.25.3
Connect to port 8766: Succeeded (0.000 sec)
Reverse lookup for 192.168.25.3
Query time: 0.000 sec
Name: winsrvr2k12.emclab.local
- После подключения к портам nsrcpd с сервера NMC вы сможете получить доступ к вкладке Hosts в NMC. Обратите внимание, что другие типы программного обеспечения безопасности или настроек также могут прерывать определенные формы связи. в некоторых случаях описанного базового тестирования может быть недостаточно.
Affected Products
NetWorkerProducts
NetWorkerArticle Properties
Article Number: 000160392
Article Type: Solution
Last Modified: 09 Jun 2025
Version: 4
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.