NMC: Hosts tab returns error - Unable to connect to Client Push daemon

Summary: When selecting the Hosts tab in the NetWorker Management Console, it takes a long time to load and eventually times out with the error: Unable to connect to Client Push daemon.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Restarting services results in all daemons receiving new dynamically assigned ports at startup.
Daemons which fail and respawn receives new assignments.
 

Selecting the Hosts tab in the NetWorker Management Console times out with the error:
Unable to connect to Client Push daemon

Cause

The client push daemon nsrcpd runs on the NetWorker server, has a dynamically assigned port from the NetWorker service port range.

  • The nsrcpd daemon is assigned a port which is not open in a system or network firewall.
  • Network security device is interrupting or closing the connection.

Resolution

  1. Attempt to access the Hosts tab in NMC which prompts the NetWorker server to start the nsrcpd service.
  2. Confirm that nsrcpd is running on the NetWorker server and which TCP port it is using:
    nsrrpcinfo -p
nsrrpcinfo -p
PROGRAM VERSION PROTOCOL PORT SERVICE
...
...
390437  1       tcp      8766 nsrcpd         Client Push
  1. On the NMC server, test access to nsrcpd assigned TCP listening port on the NetWorker server collected in the above step:
    nsrports -t {networker_servername} -p {nsrcpd_portnum}
nsrports -t nsr.amer.lan -p 8766
Forward lookup for nsr.amer.lan
Query time:              0.001 sec
Canonical name (CNAME):  nsr.amer.lan
Address (A):             192.168.x.y
Connect to port 8766:    . . . . . . * Connection timed out

Reverse lookup for 192.168.x.y
Query time:              0.003 sec
Name:                    nsr.amer.lan

  1. If there is a communication failure, confirm the service port range configured on the NetWorker server by running nsrports command locally. The default range is 7937-9936. Confirm that there are no software or hardware firewalls blocking these ports between the NMC server and NetWorker server.
nsrports -t nsr.amer.lan -p 8766
Forward lookup for winsrvr2k12
Query time:              0.001 sec
Canonical name (CNAME):  nsr.amer.lan
Address (A):             192.168.x.y
Connect to port 8766:    Succeeded (0.000 sec)

Reverse lookup for 192.168.x.y
Query time:              0.000 sec
Name:                    nsr.amer.lan
  1. Once you can connect to nsrcpd ports from the NMC server, access the Hosts tab in NMC.
NOTE: other types of security software or settings may also be interrupting or closing communications; sometimes the basic testing described may not be sufficient.

Affected Products

NetWorker

Products

NetWorker
Article Properties
Article Number: 000160392
Article Type: Solution
Last Modified: 09 Jun 2025
Version:  4
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