NetWorker: NMC progress bar stuck at 5% after launching NetWorker Administration window

Summary: This KB documents a scenario that can cause the NMC GUI progress bar to get stuck at 5% progress.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

The NetWorker Management Console (NMC) is used to connect to a NetWorker server. After attempting to connect to a NetWorker server from the NMC, a loading bar appears and does not progress beyond 5%. 
The NetWorker Web User Interface (NWUI) connects to the NetWorker server without issue. 
The NetWorker server has one or more VMware vCenter's registered on it.

The NMC server's gstd.raw reports an authentication error for the vCenter:
Linux: /opt/lgtonmc/logs/gstd.raw
Windows: C:\Program Files\EMC NetWorker\Management\GST\logs\gstd.raw
gstd NSR notice ERROR generated: "Unable to fetch data from vCenter: Cannot complete login due to an incorrect user name or password." in file "/disks/nasbld/nas83/nw/#.#/nsrwebui/modules/nsm/gstnsm.c" line #4750
 
The NetWorker server's nsrvisd-deamon.log reports login failures for one or more vCenters.
Linux: /opt/nsr/vproxy/logs/nsrvisd/nsrvisd-daemon.log
Windows: C:\Program Files \EMC NetWorker\nsr\vproxy\logs\nsrvisd/nsrvisd-daemon.log
YYYY-MM-DDTHH:mm:SS-TZ ERROR:  [##] 952aa502-3e5a-442b-99bf-80f4372bc4e0-vCenter_Name: Unable to log in to vCenter 'vCenter_Name': ServerFaultCode: Cannot complete login due to an incorrect user name or password.
YYYY-MM-DDTHH:mm:SS-TZ ERROR:  [##] 952aa502-3e5a-442b-99bf-80f4372bc4e0-vCenter_Name: Failed to load inventory from 'vCenter_Name'.

Cause

The user credentials used to log in to the vCenter is not being accepted. 

Resolution

1. On the NetWorker server, open an Administrator command prompt or root SSH session.

For each of the vCenters reporting a log in failure in the nsrvisd-daemon.log, perform the following. 


2. Using the nsrports command, verify that the NetWorker server can resolve the vCenter and connect to port 443.

nsrports -t vCenter_Name -p 443

Example:

[root@nsr ~]# nsrports -t vcsa.amer.lan -p 443
Forward lookup for vcsa.amer.lan
Query time:              0.001 sec
Canonical name (CNAME):  vcsa.amer.lan
Address (A):             192.168.9.111
Connect to port 443:     Succeeded (0.001 sec)

Reverse lookup for 192.168.9.111
Query time:              0.000 sec
Name:                    vcsa.amer.lan
NOTE: If the above command returns the wrong DNS information, or fails to connect to vCenter port 443, these issues must be resolved in the environment. Consult with your domain/network admin regarding the DNS resolution errors or port connection issues.

3. Use the nsradmin command-line utility to confirm which user account is used for the vCenter reporting login failures in the nsrvisd-daemon.log.

[root@nsr ~]# nsradmin
NetWorker administration program.
Use the "help" command for help, "visual" for full-screen mode.
nsradmin> p type: nsr hypervisor; name: vcsa.amer.lan
                        type: NSR hypervisor;
                        name: vcsa.amer.lan;
                     version: 8.0.2;
                     comment: ;
                     service: VMware VirtualCenter;
                    endpoint: "https://vcsa.amer.lan/sdk";
                    username: networker_user@vsphere.local;
                    password: *******;
                     command: nsrvim;
                       proxy: nsr.amer.lan;
              console events: Yes;
                       cloud: No;
              console cancel: Yes;
Snapshot FreeSpace Warning Threshold: 0;
Snapshot FreeSpace Failure Threshold: 0;
        restricted data zone: ;
nsradmin>
 

4. From a web browser, access the vSphere web client for the vCenter server.
5. Log in to vSphere using the account used to add the vCenter to NetWorker (see step 3).

NOTE: If you are unable to log in to vSphere with this account, consult with the VMware administrator regarding the correct password. If the login succeeds, use this password to update the credentials in NetWorker.


6. On the NetWorker server, update the password for the vCenter user account. This can be done using nsradmin, or the NetWorker Web User Interface.

nsradmin method:

A. On the NetWorker server, open and Administrator command prompt, or root shell.
B. Run: nsradmin
C. From the nsradmin command prompt, set the type to the vCenter resource:
. type: nsr hypervisor; name: vCenter_Name
NOTE: If you do not know the vCenter name, run the following command to get the vCenter names: print type: nsr hypervisor
D. Update the password for the vCenter with the correct password used to access vSphere in step 5.
update password: Correct_Password
Example:
[root@nsr ~]# nsradmin
NetWorker administration program.
Use the "help" command for help, "visual" for full-screen mode.
nsradmin> . type: nsr hypervisor; name: vcsa.amer.lan
Current query set
nsradmin> update password: !Password1
                    password: *******;
Update? y
updated resource id 198.0.90.20.0.0.0.0.196.80.99.102.192.168.9.150(3983)
nsradmin>

NWUI method:

A. Log in to the NetWorker Web User Interface (NWUI) for the NetWorker server: https://NetWorker_Address:9090/nwui
B. Go to Protection->VMware vCenters.
C. Select the vCenter reporting authentication errors. 
NOTE: When selecting the vCenter in NWUI, an alert appears stating "Error retrieving inventory tree for vCenter 'vCenter Name'.
D. With the vCenter selected, click Edit.
E. Update the Password and click Save.
Updating vCenter password
 
F. After updating the password, confirm the vCenter inventory can be seen in the vCenter Inventory window.
vCenter Inventory

7. Once credentials have been corrected for each vCenter previously reporting login failures, launch the NMC and attempt to connect to the NetWorker server. 

Additional Information

The NetWorker VMware Integration Guide provides information about the permissions needed by the VMware vCenter user account used for NetWorker VMware Protection. This guide is available through: https://www.dell.com/support/home/product-support/product/networker/docs

Affected Products

NetWorker

Products

NetWorker Family, NetWorker Series
Article Properties
Article Number: 000165440
Article Type: Solution
Last Modified: 15 Aug 2025
Version:  6
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