禁用“Snapshot Manager”时,Avamar VMware“Crash consistent”快照操作失败

Summary: 当 SnapShot Manager 处于禁用状态时,Avamar 快照将失败。

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

在执行已禁用停顿功能的快照时,vCenter 6.5 或更高版本上的 VMware 映像备份失败,并显示以下致命错误消息。 
avvcbimage Info <43655>: Creating snapshot 'Avamar-<epoch><cid>', quiesceFS=FALSE
avvcbimage Info <42643>: Using vSphere CreateSnapshotTaskEX: snapshot name (Avamar-<epoch><cid>)
avvcbimage Info <14631>: Snapshot 'Avamar-<epoch><cid>' creation for VM '[Avamar] winvm/winvm.vmx' task still in progress, sleep for 3 sec
avvcbimage Warning <16277>: vSphere Task failed (application quiesce): An error occurred while quiescing the virtual machine. See the virtual machine's event log for details.
avvcbimage Warning <43652>: Snapshot 'Avamar-<epoch><cid>' creation for VM '[Avamar] winvm/winvm.vmx' task creation encountered a quiesce problem
avvcbimage Error <43651>: Crash level consistent snapshot quiesce failure.
avvcbimage FATAL <0000>: [IMG0003] The VMX '[Avamar] winvm/winvm.vmx' could not be snapshot

Cause

Avamar 代理未使用名为“SnapShot Manager”的服务。如果未使用此服务,日志将显示以下内容:   
avvcbimage Info <40643>: NOT using SnapShot Manager - using proxy method of calling vSphere API functions
SnapShot Manager 是在 Avamar 应用工具节点上运行的服务,可通过 TCP 8543 (https://avamar.example.com:8543/snapshotmanager/) 访问。当所有代理使用此服务时,所有快照操作(创建、删除、整合)任务将集中到 Avamar Server。如果未使用此服务,代理将通过标准 vSphere API 执行自己的快照操作。

vSphere API quiesce_fs=false 快照机制中引入了 Avamar 软件缺陷:    
  • 带热修复程序的 Avamar 18.2 代理309856(或更高版本)
  • Avamar 19.1 代理  
由于以下两个潜在原因,Avamar Snapshot Manager 可能不可用:   
  • 在其中的网络或防火墙中,日志中会显示以下内容:   
avvcbimage Info <44028>: GET: curl_easy_perform -failed. Path: /snapshotmanager/about/, Curl Error: 7
avvcbimage Info <44028>: GET: curl_easy_perform -failed. Path: /snapshotmanager/about/, Curl Error: 28
  • 用户已在代理上的 avvcbimageAll.cmd 文件中禁用或删除 Snapshot Manager 选项,在这种情况下,会看到以下内容:   
admin@182proxy:~> grep snapshotManager /usr/local/avamarclient/var/avvcbimageAll.cmd
##--snapshotManager=10.2X0.1X6.1X1

admin@182proxy:~> grep snapshotManager /usr/local/avamarclient/var/avvcbimageAll.cmd
admin@182proxy:~>

Resolution

解决办法:    
确认正在使用 Avamar Snapshot Manager:   
  • 验证 Avamar 代理是否可以在 TCP 8543 上连接 Avamar 服务
或者 
  • 重新注册代理或将此行添加回
    /usr/local/avamarclient/var/avvcbimageAll.cmd
     不带任何注释 #:   
--snapshotManager==<avamar-ip-address or hostname>
分辨率:
此问题已在 Avamar 19.1+ 代理累积热修复程序中得到解决。  请为您的版本安装最新的新更新以解决。

Affected Products

Avamar Client for VMware

Products

Avamar, Avamar Client for VMware
Article Properties
Article Number: 000172862
Article Type: Solution
Last Modified: 10 Nov 2023
Version:  4
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.