L'operazione snapshot "Crash Consistent" di Avamar VMware ha esito negativo quando "Snapshot Manager" è disabilitato
Summary: Le snapshot Avamar hanno esito negativo quando SnapShot Manager è disabilitato.
This article applies to
This article does not apply to
This article is not tied to any specific product.
Not all product versions are identified in this article.
Symptoms
I backup delle immagini VMware su vCenter 6.5 o versioni successive non riescono con il seguente messaggio di errore IRREVERSIBILE quando si esegue una snapshot con la funzione di disattivazione disabilitata.
avvcbimage Info <43655>: Creating snapshot 'Avamar-<epoch><cid>', quiesceFS=FALSE avvcbimage Info <42643>: Using vSphere CreateSnapshotTaskEX: snapshot name (Avamar-<epoch><cid>) avvcbimage Info <14631>: Snapshot 'Avamar-<epoch><cid>' creation for VM '[Avamar] winvm/winvm.vmx' task still in progress, sleep for 3 sec avvcbimage Warning <16277>: vSphere Task failed (application quiesce): An error occurred while quiescing the virtual machine. See the virtual machine's event log for details. avvcbimage Warning <43652>: Snapshot 'Avamar-<epoch><cid>' creation for VM '[Avamar] winvm/winvm.vmx' task creation encountered a quiesce problem avvcbimage Error <43651>: Crash level consistent snapshot quiesce failure. avvcbimage FATAL <0000>: [IMG0003] The VMX '[Avamar] winvm/winvm.vmx' could not be snapshot
Cause
Il proxy Avamar non utilizza un servizio denominato "SnapShot Manager". Quando questo servizio non viene utilizzato, i registri mostrano quanto segue:
SnapShot Manager è un servizio in esecuzione sugli utility node Avamar ed è accessibile tramite TCP 8543 (https://avamar.example.com:8543/snapshotmanager/). Quando questo servizio viene utilizzato da tutti i proxy, tutte le attività delle snapshot (creazione, eliminazione, consolidamento) vengono centralizzate su Avamar Server. Quando questo servizio non viene utilizzato, il proxy accetta le proprie operazioni di snapshot tramite l'API vSphere standard.
Esiste un difetto del software Avamar con il meccanismo vSphere API quiesce_fs=false snapshot introdotto in:
avvcbimage Info <40643>: NOT using SnapShot Manager - using proxy method of calling vSphere API functions
Esiste un difetto del software Avamar con il meccanismo vSphere API quiesce_fs=false snapshot introdotto in:
- Proxy Avamar 18.2 con hot fix 309856 (o versioni successive)
- Proxy Avamar 19.1
- La rete o il firewall, nel qual caso, nei registri viene visualizzato quanto segue:
avvcbimage Info <44028>: GET: curl_easy_perform -failed. Path: /snapshotmanager/about/, Curl Error: 7
Oppure
avvcbimage Info <44028>: GET: curl_easy_perform -failed. Path: /snapshotmanager/about/, Curl Error: 28
- L'utente ha disabilitato o rimosso l'opzione Snapshot Manager nel file avvcbimageAll.cmd sul proxy, nel qual caso viene visualizzato quanto segue:
admin@182proxy:~> grep snapshotManager /usr/local/avamarclient/var/avvcbimageAll.cmd ##--snapshotManager=10.2X0.1X6.1X1
Oppure
admin@182proxy:~> grep snapshotManager /usr/local/avamarclient/var/avvcbimageAll.cmd admin@182proxy:~>
Resolution
Soluzione alternativa:
Verificare che Avamar Snapshot Manager sia utilizzato da:
Risoluzione:
Questo problema è stato risolto negli hot fix cumulativi del proxy Avamar 19.1+. Installare il nuovo aggiornamento più recente per la propria versione per risolvere il problema.
Verificare che Avamar Snapshot Manager sia utilizzato da:
- Verifica della possibilità per il proxy Avamar di connettere il servizio Avamar su TCP 8543
OPPURE
- Nuova registrazione del proxy o aggiunta di nuovo questa riga a
/usr/local/avamarclient/var/avvcbimageAll.cmd
senza alcun commento n.:
--snapshotManager==<avamar-ip-address or hostname>
Questo problema è stato risolto negli hot fix cumulativi del proxy Avamar 19.1+. Installare il nuovo aggiornamento più recente per la propria versione per risolvere il problema.
Affected Products
Avamar Client for VMwareProducts
Avamar, Avamar Client for VMwareArticle Properties
Article Number: 000172862
Article Type: Solution
Last Modified: 10 Nov 2023
Version: 4
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.