Операция создания снимка Avamar VMware «Crash consistent» завершается сбоем, когда параметр Snapshot Manager отключен
Summary: При отключении SnapShot Manager происходит сбой моментальных снимков Avamar.
This article applies to
This article does not apply to
This article is not tied to any specific product.
Not all product versions are identified in this article.
Symptoms
Сбой резервного копирования образа VMware в vCenter 6.5 или более поздней версии со следующим сообщением об ошибке FATAL при выполнении моментального снимка с отключенной функцией перевода в пассивное состояние.
avvcbimage Info <43655>: Creating snapshot 'Avamar-<epoch><cid>', quiesceFS=FALSE avvcbimage Info <42643>: Using vSphere CreateSnapshotTaskEX: snapshot name (Avamar-<epoch><cid>) avvcbimage Info <14631>: Snapshot 'Avamar-<epoch><cid>' creation for VM '[Avamar] winvm/winvm.vmx' task still in progress, sleep for 3 sec avvcbimage Warning <16277>: vSphere Task failed (application quiesce): An error occurred while quiescing the virtual machine. See the virtual machine's event log for details. avvcbimage Warning <43652>: Snapshot 'Avamar-<epoch><cid>' creation for VM '[Avamar] winvm/winvm.vmx' task creation encountered a quiesce problem avvcbimage Error <43651>: Crash level consistent snapshot quiesce failure. avvcbimage FATAL <0000>: [IMG0003] The VMX '[Avamar] winvm/winvm.vmx' could not be snapshot
Cause
Прокси-сервер Avamar не использует службу SnapShot Manager. Если эта служба не используется, в журналах отображаются следующие данные:
SnapShot Manager — это сервис, который работает на служебных узлах Avamar и доступен через TCP 8543 (https://avamar.example.com:8543/snapshotmanager/). При использовании этой службы всеми прокси все операции создания снимков (создание, удаление, консолидация) централизованы для сервера Avamar. Если эта служба не используется, прокси выполняет собственные операции создания моментальных снимков с помощью стандартного API-интерфейса vSphere.
Имеется дефект программного обеспечения Avamar с API-интерфейсом vSphere quiesce_fs=false механизм моментальных снимков, представленный в:
avvcbimage Info <40643>: NOT using SnapShot Manager - using proxy method of calling vSphere API functions
Имеется дефект программного обеспечения Avamar с API-интерфейсом vSphere quiesce_fs=false механизм моментальных снимков, представленный в:
- Прокси-сервер Avamar 18.2 с исправлением 309856 (или более поздней версии)
- Прокси-сервер Avamar 19.1
- В этом случае в журналах сети или брандмауэра отображается следующее:
avvcbimage Info <44028>: GET: curl_easy_perform -failed. Path: /snapshotmanager/about/, Curl Error: 7
или
avvcbimage Info <44028>: GET: curl_easy_perform -failed. Path: /snapshotmanager/about/, Curl Error: 28
- Пользователь отключает или удаляет параметр Snapshot Manager в файле avvcbimageAll.cmd на прокси, в этом случае отображается следующее:
admin@182proxy:~> grep snapshotManager /usr/local/avamarclient/var/avvcbimageAll.cmd ##--snapshotManager=10.2X0.1X6.1X1
или
admin@182proxy:~> grep snapshotManager /usr/local/avamarclient/var/avvcbimageAll.cmd admin@182proxy:~>
Resolution
Временное решение.
Убедитесь, что Avamar Snapshot Manager используется:
Разрешение:
Эта проблема устранена в накопительных исправлениях Avamar 19.1+ прокси. Установите последнее обновление для вашей версии, чтобы устранить проблему.
Убедитесь, что Avamar Snapshot Manager используется:
- Проверка возможности подключения прокси-сервера Avamar к службе Avamar на TCP 8543
ИЛИ
- Перерегистрируйте прокси-сервер или снова подключите эту строку к
/usr/local/avamarclient/var/avvcbimageAll.cmd
без комментариев No:
--snapshotManager==<avamar-ip-address or hostname>
Эта проблема устранена в накопительных исправлениях Avamar 19.1+ прокси. Установите последнее обновление для вашей версии, чтобы устранить проблему.
Affected Products
Avamar Client for VMwareProducts
Avamar, Avamar Client for VMwareArticle Properties
Article Number: 000172862
Article Type: Solution
Last Modified: 10 Nov 2023
Version: 4
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.