Operace "konzistentního" snapshotu systému Avamar VMware se nezdaří, pokud je zakázána možnost "Snapshot Manager".

Summary: Snapshoty Avamar selžou, pokud je zakázána aplikace SnapShot Manager.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Zálohování bitové kopie VMware na nástroji vCenter 6.5 nebo novějším selhává a zobrazuje se následující závažná chybová zpráva při provádění snapshotu se zakázanou funkcí quiesce. 
avvcbimage Info <43655>: Creating snapshot 'Avamar-<epoch><cid>', quiesceFS=FALSE
avvcbimage Info <42643>: Using vSphere CreateSnapshotTaskEX: snapshot name (Avamar-<epoch><cid>)
avvcbimage Info <14631>: Snapshot 'Avamar-<epoch><cid>' creation for VM '[Avamar] winvm/winvm.vmx' task still in progress, sleep for 3 sec
avvcbimage Warning <16277>: vSphere Task failed (application quiesce): An error occurred while quiescing the virtual machine. See the virtual machine's event log for details.
avvcbimage Warning <43652>: Snapshot 'Avamar-<epoch><cid>' creation for VM '[Avamar] winvm/winvm.vmx' task creation encountered a quiesce problem
avvcbimage Error <43651>: Crash level consistent snapshot quiesce failure.
avvcbimage FATAL <0000>: [IMG0003] The VMX '[Avamar] winvm/winvm.vmx' could not be snapshot

Cause

Server proxy Avamar nepoužívá službu nazvanou "SnapShot Manager". Pokud tato služba není používána, zobrazí se v protokolech následující:   
avvcbimage Info <40643>: NOT using SnapShot Manager - using proxy method of calling vSphere API functions
SnapShot Manager je služba spuštěná v uzlech nástrojů Avamar, která je přístupná prostřednictvím protokolu TCP 8543 (https://avamar.example.com:8543/snapshotmanager/). Pokud tuto službu používají všichni proxy, všechny operace snapshotů (vytvoření, odstranění, konsolidace) jsou centralizované na server Avamar. Pokud tato služba není použita, server proxy provádí vlastní operace snapshotu prostřednictvím standardního rozhraní API vSphere.

Došlo k závadě softwaru Avamar s rozhraním vSphere API quiesce_fs=mechanismus falešného snapshotu, který byl zaveden v následujících systémech:    
  • Server proxy Avamar 18.2 s opravou hotfix 309856 (nebo novější)
  • Proxy Avamar 19.1  
Nástroj Avamar Snapshot Manager může být nedostupný kvůli dvěma možným příčinám:   
  • Síť nebo brána firewall v takovém případě se v protokolech zobrazí následující:   
avvcbimage Info <44028>: GET: curl_easy_perform -failed. Path: /snapshotmanager/about/, Curl Error: 7
Nebo
avvcbimage Info <44028>: GET: curl_easy_perform -failed. Path: /snapshotmanager/about/, Curl Error: 28
  • Uživatel deaktivoval nebo odebral možnost Snapshot Manager v souboru avvcbimageAll.cmd na serveru proxy. V takovém případě se zobrazí následující:   
admin@182proxy:~> grep snapshotManager /usr/local/avamarclient/var/avvcbimageAll.cmd
##--snapshotManager=10.2X0.1X6.1X1

Nebo

admin@182proxy:~> grep snapshotManager /usr/local/avamarclient/var/avvcbimageAll.cmd
admin@182proxy:~>

Resolution

Zástupné řešení:    
Ověřte, že nástroj Avamar Snapshot Manager používá:   
  • Ověření, zda server proxy Avamar může připojit službu Avamar k protokolu TCP 8543
NEBO 
  • Opětovná registrace serveru proxy nebo opětovné přidání tohoto řádku zpět do
    /usr/local/avamarclient/var/avvcbimageAll.cmd
     bez jakéhokoli komentáře č.:   
--snapshotManager==<avamar-ip-address or hostname>
Rozlišení:
Tento problém byl vyřešen v kumulativních opravách hotfix serveru Avamar 19.1+ proxy.  Pro vyřešení problému nainstalujte nejnovější novou aktualizaci.

Affected Products

Avamar Client for VMware

Products

Avamar, Avamar Client for VMware
Article Properties
Article Number: 000172862
Article Type: Solution
Last Modified: 10 Nov 2023
Version:  4
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.