Data Protection Central (DPC) is producing an Error 502 while accessing the UI after initial install
Summary: This KB covers how to resolve errors with logging into Data Protection Central (DPC) UI after initial install of DPC.
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Symptoms
After install of DPC, when attempting to log in to the DPC UI, get an HTTP error 502.
After checking the DPC services, find several services in a filed state.
In the /var/log/dpc/elg/elg.log file, find errors similar to the following.
2021-02-16 15:35:57,340 ERROR main o.s.b.SpringApplication Application run failed com.emc.clp.spi.UnavailableException: Unable to init ELG ... Caused by: java.util.concurrent.ExecutionException: java.util.concurrent.CompletionException: java.lang.IllegalStateException: Could not create URI object: Illegal character in hostname at index 10: https://dp_central.lab.dell.com/pf-admin-api/v1/oauth/clients
Cause
An illegal character in the hostname of the DPC causes this.
Resolution
To resolve this issue, re-deploy DPC with a hostname that has only supported characters.
In the example above, the hostname is "dp_central.lab.dell.com." An underscore "_" is not a supported character.
DPC hostname only supports the following criteria.
- Each element of the hostname must be between 1 to 63 characters long.
- The entire hostname, including the dots, cannot be more than 253 characters long.
- Valid characters are letters a to z, digits 0 to 9 and the hyphen "-," the hostname cannot start with a hyphen "-."
- Each element is separated by a dot.
Affected Products
Data Protection CentralArticle Properties
Article Number: 000183400
Article Type: Solution
Last Modified: 11 Feb 2025
Version: 4
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