Secure Connect Gateway - Unable to connect to device due to MQTT error

Summary: This article explains how to solve a situation when after updating from SRSv3.52 to Secure Connect Gateway (SCG), it fails to make a connection. "Error: Failed to start session, due to RA Forwarder/MQTT connection timeout from available gateways." ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

This error message appears on Secure Connect Gateway after updating from SRSv3.52 to SCG and trying to establish a connection:
 Error: Failed to start session, due to RA Forwarder/MQTT connection timeout from available gateways

Cause

This error is caused by a corrupted or missing keystore.

Resolution

  1. Login into SCG as root
  2. Run the following commands:
    - docker exec -i esrsde-app rm /opt/esrsve/gateway/clientkeystore.jks
    - docker exec -i esrsde-app /opt/esrsve/gateway/suseveupgrade.sh -configuresystem
  3. Reboot your SCG

Affected Products

Secure Connect Gateway - Virtual Edition

Products

Secure Connect Gateway
Article Properties
Article Number: 000198045
Article Type: Solution
Last Modified: 22 Jul 2024
Version:  2
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.