Mouse Cursor is Not Visible on White Background of Text Editors in Remote Citrix Session

Summary: This article provides steps to resolve the mouse cursor not being visible when moved over a text editor window (for example Notepad, Outlook, Word, or Windows 10 search bar) while connected to a Citrix remote session. ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Affected Products:

  • Citrix Workspace App for Linux

Affected Operating Systems:

  • Dell ThinOS

Inside a Citrix remote session, hovering the mouse cursor on text editor windows, such as the Windows search bar or Notepad, the mouse is white on a white background making it invisible.

Note: The issue is showing on Linux fat clients too.

Cause

Citrix VDA 2203 CU2 and later uses Citrix Indirect Display (IDD) display adapter rather than the Citrix Display Only (DOD) that was used on the previous versions. This can be confirmed by running the dxdiag utility on the VDA and checking the Display tab:

DirectX Diagnostic Tool

Citrix Workspace app for Linux (CWA) cursor has a limitation in this scenario and is unable to invert the color on a white background.

Resolution

This issue has been resolved in Linux CWA 2308.

As a workaround it is possible to force the VDA to use the Citrix Display Only adapter adding the registry key below:

Warning: The next step is a Windows Registry edit:
  1. Open the Windows Registry Editor on the VDA by typing regedit into a Run window and selecting OK.
  2. Type regedit
    Open the Windows Registry Editor
  3. Add the registry key below:
    Path: HKLM\Software\Citrix\Graphics
        Key: AdapterMerits
        [DWORD]: CitrixDoD
        [value]: 3
    

    Create registry key
  4. Reboot the VDA.
    Note: Notice that for nonpersistent Citrix Catalogs, the changes must be added to the base image and published.

Affected Products

Citrix Software, Dell ThinOS
Article Properties
Article Number: 000216895
Article Type: Solution
Last Modified: 13 Aug 2024
Version:  3
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.