Data Domain: DDBMA Standalone SQL backup failed because Unable to set Asset ID

Summary: DDBMA: Standalone SQL backup failed because Unable to set Asset ID

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

The following error is observed when using stand-alone DDBMA without PowerProtect Data Manager.
2023-08-01T05:52:42.961Z [TRACE_ID:8534b11c134ed526]3  ddbmsqlsv PowerProtect Data Manager critical Unable to set Asset ID.
The following message may also be seen:
Verify that the agent-id.yml file exists in path C:\Program Files\DPSAPPS\AgentService 

Cause

This is a known issue.
The self-service backup shows successful in the popup whereas it fails with the error "ddbmsqlsv PowerProtect Data Manager critical Unable to set Asset ID" when agent-id.yml file is absent while .ddbmcon.gatherinfo file is present.

File locations:
C:\Program Files\DPSAPPS\AgentService\agent-id.yml
C:\Program Files\DPSAPPS\MSAPPAGENT\settings\.ddbmcon.gatherinfo

Resolution

Resolution:
The issue shall be resolved in v19.15.

Workaround:
Rename .ddbmcon.gatherinfo and the backup works correctly.
It is not required for stand-alone DDBMA backup.

Affected Products

Microsoft App Agent
Article Properties
Article Number: 000218733
Article Type: Solution
Last Modified: 03 Jan 2024
Version:  2
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.