PowerProtect Data Manager: User interface admin user gets locked due to failed login attempts

Summary: PowerProtect Data Manager 19.15: The admin user gets locked from logging in due to many failed login attempts.

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Symptoms

- In ECDM UI logs:

  Body: {
    code: 423,
    reason: 'Account is locked due to multiple unsuccessful login attempts.'
    remediation: 'Please try again in 5 minutes or contact your administrator.'

- In aaa.log

2024-05-11T21:15:57.095Z INFO [] [https-jsse-nio-9090-exec-4] [][][][TRACE_ID:a9f380e334aa8f14][] [c.e.b.a.s.c.ControllerExceptionHandler.responseEntity(251)] - com.emc.brs.aaa.server.exception.LoginRequestException: {"code":401,"reason":"Unauthorized login request for user 'admin'.","remediation":"Check to ensure that the login credentials are correct.","details":["If problem persists, reset password for user 'admin'."]}
com.emc.brs.aaa.server.exception.LoginRequestException: Unauthorized login request for user 'admin'.: If problem persists, reset password for user 'admin'.

- In Zuul.log

2024-05-11T21:00:25.265Z INFO [] [https-jsse-nio-8443-exec-15571] [00000000-0000-4000-a000-000000000000][][][][] [c.e.b.z.f.p.AuthenticationFilter.checkCertificate(334)] - Found Certificate for Agent tamppdmrep01.tamkeen.local
2024-05-11T21:00:25.265Z INFO [] [https-jsse-nio-8443-exec-15571] [00000000-0000-4000-a000-000000000000][][][][] [c.e.b.z.f.p.AuthenticationFilter.processLogin(381)] - Redirecting certificate login for tamppdmrep01.tamkeen.local/2bc98750-7675-0136-29e9-5bbd3ce729b0


 - Run the following command to get the list of the IP addresses where the login attempts are coming from (change the date in search if mandatory)

# cd /var/log/brs/zuul
# zgrep -i 'login' zuul.2024-* | awk -F remoteHost '{ print $2 }' | sort | uniq -c
   3683  10.4.157.200, uri /api/v2/login
    763  10.4.128.200, uri /api/v2/login
    190  127.0.57.200, uri /api/v2/login

Cause

  • The admin account locked because there are too many attempts from a certain IP address which corresponds to the DPA IP address.
  • In DPA, there is a credential created for connection to PowerProtect Data Manager. In this case, it's "admin" with the same password. That password has been changed, but not updated in DPA. That credential in DPA must be updated with the correct password.

Resolution

  • In DPA UI, navigate to System Settings > Credentials…edit the one used for PPDM connection and update the password. 
  • If you are using the credentials for username and password in PowerProtect Data Manager UI login and the same for DPA logins. It is recommended to create a new credential for the DPA logins so it wont affect the PowerProtect Data Manager UI logins.  To do so, please refer to the relevant Data Protection Advisor documentation.
Article Properties
Article Number: 000226331
Article Type: Solution
Last Modified: 08 Apr 2025
Version:  1
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