NetWorker: NMC workflow details error "unable to obtain root job list"
Zhrnutie: The NetWorker Management Console (NMC) workflow "Show Details" option generates an error message: "unable to obtain root job list."
Tento článok sa vzťahuje na
Tento článok sa nevzťahuje na
Tento článok nie je viazaný na žiadny konkrétny produkt.
V tomto článku nie sú uvedené všetky verzie produktov.
Symptómy
Clicking Show Details on any workflow in NMC results in this error message:
Príčina
The root cause of the issue could be attributed to missing exchanges or corruption in RabbitMQ's data structures.
Riešenie
- On the NetWorker server, open an Admin PowerShell prompt or root shell. Run the following commands to stop the NetWorker and NMC services:
Linux: nsr_shutdown ; sleep 10 ; systemctl stop gst
Windows: net stop nsrexecd /y
- Rename the RabbitMQ tmp folder:
Linux: /nsr/tmp/rabbitmq
Windows: C:\Program Files\EMC NetWorker\nsr\tmp\RabbitMQ
- Start the NetWorker server and NMC services. When RabbitMQ was renamed, the service startup created new files, including a new data directory:
Linux: systemctl start networker ; sleep 10 ; systemctl start gst
Windows (PowerShell): net start nsrd ; Start-Sleep 10 ; net start gstd
Vlastnosti článku
Číslo článku: 000332286
Typ článku: Solution
Dátum poslednej úpravy: 15 dec 2025
Verzia: 1
Nájdite odpovede na svoje otázky od ostatných používateľov spoločnosti Dell
Služby podpory
Skontrolujte, či sa na vaše zariadenie vzťahujú služby podpory.