Skip to main content
  • Place orders quickly and easily
  • View orders and track your shipping status
  • Create and access a list of your products
  • Manage your Dell EMC sites, products, and product-level contacts using Company Administration.

Dell EMC SmartFabric OS10 User Guide Release 10.5.0

Advertise VLAN Name TLVs

You can configure the system to advertise the names of VLANs in LLDPDUs. Configure the VLAN names before you configure the system to advertise VLAN names.

By default, this feature is disabled. After you enable this feature, the system starts sending LLDPDUs with the configured name of the default VLAN. If the default VLAN does not have a configured name, the system does not send an LLDPDU with a VLAN name TLV.

Transmit VLAN name of the default VLAN

  1. Enter INTERFACE mode from CONFIGURATION mode.

    interface ethernet 1/1/1
  2. Enable the vlan-name option in INTERFACE mode.

    lldp tlv-select dot1-tlv vlan-name
  3. Enter INTERFACE VLAN mode from CONFIGURATION mode.

    interface vlan 1
  4. Specify a name for VLAN 1 in INTERFACE VLAN mode.

    vlan-name vlan1

Transmit the VLAN names of a specific set of VLANs

When you configure the interface to send the names of specific VLANs using lldp vlan-name-tlv allowed vlan command, the interface can transmit a maximum of eight VLAN names. If you specify 10 VLANs and the default VLAN has a name, the interface transmits LLDPDUs with VLAN names of the default VLAN and the first seven VLANs configured with a name. If the default VLAN does not have a name, the interface transmits the VLAN names of the first eight VLANs that have a name.

  1. Create a VLAN in CONFIGURATION mode.

    interface vlan vlan-id
  2. Specify a name for the required VLANs in INTERFACE mode.

    vlan-name vlan-name
  3. Configure Port mode as trunk from INTERFACE mode.

    switchport mode trunk
  4. Enable the vlan-name option in INTERFACE mode.

    lldp tlv-select dot1-tlv vlan-name
  5. Configure the interface to be an untagged member of the created VLANs in INTERFACE mode.

    switchport trunk allowed vlan vlan-range
  6. Configure the interface to send the names of specific VLANs in PDUs in INTERFACE mode.

    lldp vlan-name-tlv allowed vlan vlan-ids

Examples for configuring the system to transmit VLAN name in TLVs

Specify names for VLANs from 1 to 10 and configure ethernet 1/1/1 interface to transmit the names of nine VLANs. The interface is not explicitly configured to transmit the name of the default VLAN which is VLAN 1.

OS10# configure terminal
OS10(config)# interface vlan 1
OS10(conf-if-vl-1)#vlan-name vlan1
OS10(conf-if-vl-1)# exit
OS10(config)# interface vlan 2
OS10(conf-if-vl-2)#vlan-name vlan2
OS10(config)# interface vlan 3
OS10(conf-if-vl-3)#vlan-name vlan4
OS10(config)# interface vlan 4
OS10(conf-if-vl-4)#vlan-name vlan4
OS10(config)# interface vlan 5
OS10(conf-if-vl-5)#vlan-name vlan5
OS10(config)# interface vlan 6
OS10(conf-if-vl-6)#vlan-name vlan6
OS10(config)# interface vlan 7
OS10(conf-if-vl-7)#vlan-name vlan7
OS10(config)# interface vlan 8
OS10(conf-if-vl-8)#vlan-name vlan8
OS10(config)# interface vlan 9
OS10(conf-if-vl-9)#vlan-name vlan9
OS10(config)# interface vlan 10
OS10(conf-if-vl-10)#vlan-name vlan10
OS10(config)# interface ethernet 1/1/1
OS10(conf-if-eth1/1/1)# switchport mode trunk
OS10(conf-if-eth1/1/1)# switchport trunk allowed vlan 2-10
OS10(config)# interface ethernet 1/1/1
OS10(conf-if-eth1/1/1)#lldp vlan-name-tlv allowed vlan 2,3,4,5,6,7,8,9,10

The interface transmits the name of the default VLAN even if the default VLAN ID is not explicitly configured. The interface transmits the first eight VLAN names and excludes the names of VLAN 9 and VLAN 10. Following shows that the interface transmits the names of VLANs 1 to 8:

OS10# show lldp interface ethernet 1/1/1 local-device
Device ID: 34:17:eb:f2:05:c4
Port ID: ethernet1/1/1
System Name: OS10
Capabilities: Router, Bridge, Repeater
System description:
    Dell EMC Networking OS10 Enterprise.
    Copyright (c) 1999-2019 by Dell Inc. All Rights Reserved.
    System Description: OS10 Enterprise.
    OS Version: 10.4.9999EX.
    System Type: S4048-ON
Port description: ethernet1/1/1
Time To Live: 120
Maximum size of LLDP PDU: 1500
Current LLDP PDU Size: 387
LLDP PDU Truncated(Too many TLV's): false
VLAN Name(s):
    VLAN         NAME
 ---------------------
     1        vlan1
     2        vlan2
     3        vlan3
     4        vlan4
     5        vlan5
     6        vlan6
     7        vlan7
     8        vlan8
Maximum size of LLDP PDU: 1500
Current LLDP PDU Size: 386
LLDP PDU Truncated(Too many TLV's): false
LLDP MED Capabilities:
    Supported:
           LLDP-MED Capabilities,
           Network Policy,
           Inventory Management
    Current:
           LLDP-MED Capabilities,
           Network Policy
LLDP MED Device Type: Network connectivity

Following example shows the name of VLAN 3 is deleted:

OS10(conf-if-eth1/1/1)# no lldp vlan-name-tlv allowed vlan 3

Following output shows that the interface deletes VLAN 3 and starts sending the name of VLAN 9:

OS10# show lldp interface ethernet 1/1/1 local-device
Device ID: 34:17:eb:f2:05:c4
Port ID: ethernet1/1/1
System Name: OS10
Capabilities: Router, Bridge, Repeater
System description:
    Dell EMC Networking OS10 Enterprise.
    Copyright (c) 1999-2019 by Dell Inc. All Rights Reserved.
    System Description: OS10 Enterprise.
    OS Version: 10.4.9999EX.
    System Type: S4048-ON
Port description: ethernet1/1/1
Time To Live: 120
Maximum size of LLDP PDU: 1500
Current LLDP PDU Size: 387
LLDP PDU Truncated(Too many TLV's): false
VLAN Name(s):
    VLAN         NAME
 ---------------------
     1        vlan1
     2        vlan2
     4        vlan4
     5        vlan5
     6        vlan6
     7        vlan7
     8        vlan8
     9        vlan9
Maximum size of LLDP PDU: 1500
Current LLDP PDU Size: 386
LLDP PDU Truncated(Too many TLV's): false
LLDP MED Capabilities:
    Supported:
           LLDP-MED Capabilities,
           Network Policy,
           Inventory Management
    Current:
           LLDP-MED Capabilities,
           Network Policy
LLDP MED Device Type: Network connectivity

Rate this content

Accurate
Useful
Easy to understand
Was this article helpful?
0/3000 characters
  Please provide ratings (1-5 stars).
  Please provide ratings (1-5 stars).
  Please provide ratings (1-5 stars).
  Please select whether the article was helpful or not.
  Comments cannot contain these special characters: <>()\