Skip to main content
  • Place orders quickly and easily
  • View orders and track your shipping status
  • Create and access a list of your products
  • Manage your Dell EMC sites, products, and product-level contacts using Company Administration.

Dell EMC SmartFabric OS10 User Guide Release 10.5.0

Redistribute iBGP route to OSPF

When you configure the system redistribute BGP routes to OSPF, by default, the system redistributes only the eBGP routes. To redistribute iBGP routes to OSPF, configure a route-map and apply it to the redistribute command under the OSPF configuration.

Sample configuration

The following sample topology has two switches, Core 1 and Core 2, that are connected to each other and share routes using OSPF. A border router BR is connected to Core 1 and shares routes using internal BGP. Core 1 redistributes the routes that are learned by iBGP to OSPF to Core 2.

iBGP to OSPF redistribution

Configuration on BR

BR has BGP configured which forms BGP neighbor adjacency with Core 1.

interface Loopback0
 ip address 192.168.100.1/24
!
interface ethernet1/1/1
	no shutdown
	no switchport
 ip address 10.10.9.1
!
router bgp 20
 network 192.168.100.0
 neighbor 10.10.9.2 remote-as 20
   address-family ipv4 unicast

Configuration on Core 1

Core 1 has both OSPF and BGP configured. Core 1 has OSPF neighbor adjacency with Core 2 and BGP neighbor adjacency with BR. The iBGPtoOSPF prefix-list is configured and applied to a route-map. The match ip address prefix-list iBGPtoOSPF command processes the iBGP-learned routes.

ip prefix-list iBGPtoOSPF seq 15 permit 192.168.100.0/24 
route-map iBGPtoOSPF permit 20
  match ip address prefix-list iBGPtoOSPF 
!
interface ethernet1/1/1
	no shutdown
	no switchport
  ip address 10.10.30.2/24
  ip router ospf 10 area 0.0.0.0
!
interface ethernet1/1/2
	no shutdown
	no switchport
  ip address 10.10.9.2/24
!
router ospf 10
  router-id 2.2.2.2
  redistribute bgp 20 route-map iBGPtoOSPF
!
router bgp 20 
	neighbor 10.10.9.1 
	remote-as 20 
	address-family ipv4 unicast
	allowas-in 1

Configuration on Core 2

Core 2 has OSPF configured which forms neighbor adjacency with Core 1.

interface ethernet1/1/1
	no shutdown
	no switchport
  ip address 10.10.30.3/24
  ip router ospf 10 area 0.0.0.0
  no shutdown
!
!
router ospf 10
  router-id 3.3.3.3

Sample IPv6 configuration

The following sample topology has two switches, Core 1 and Core 2, that are connected to each other and share routes using OSPF. A border router BR is connected to Core 1 and shares routes using BGP. Core 1 redistributes the routes that are learned by iBGP to OSPF and shares to other routers. This network uses IPv6 addressing.

Configuration on BR

BR has BGP configured which forms BGP neighbor adjacency with Core 1.

interface Loopback0
 ipv6 address 2020::1/64
!
interface ethernet1/1/1
	no switchport
 ip address 2030::1/64
!
!
address-family ipv6 unicast
router bgp 20
 neighbor 2030::2 remote-as 20

Configuration on Core 1

Core 1 has both OSPF and BGP configured. Core 1 has OSPF neighbor adjacency with Core 2 and BGP neighbor adjacency with BR. The iBGPtoOSPF prefix-list is configured and applied to a route-map. The match ip address prefix-list iBGPtoOSPF command processes the iBGP-learned routes.

ip prefix-list iBGPtoOSPF seq 15 permit 2020::1/64 
route-map iBGPtoOSPF permit 20
  match ip address prefix-list iBGPtoOSPF 
 !
!
interface ethernet1/1/1
	no switchport
  ipv6 address 2035::1/64
  ipv6 ospf 10 area 0.0.0.0
  no shutdown
!
interface Ethernet1/1/2
	no switchport
  ipv6 address 2030::2/64
  no shutdown
!
router ospfv3 10
  router-id 2.2.2.2
  redistribute bgp 10 route-map iBGPtoOSPF
!
router bgp 20 
neighbor 2030::1 
remote-as 20 
address-family ipv6 unicast
activate
allowas-in 1

Configuration on Core 2

Core 2 has OSPF configured which forms neighbor adjacency with Core 1.

interface Ethernet 1/1/1
	no switchport
  ipv6 address 2035::2/64
  ipv6 ospf 10 area 0.0.0.0
  no shutdown
!
router ospfv3 10
  router-id 3.3.3.3


Rate this content

Accurate
Useful
Easy to understand
Was this article helpful?
0/3000 characters
  Please provide ratings (1-5 stars).
  Please provide ratings (1-5 stars).
  Please provide ratings (1-5 stars).
  Please select whether the article was helpful or not.
  Comments cannot contain these special characters: <>()\