Skip to main content
  • Place orders quickly and easily
  • View orders and track your shipping status
  • Create and access a list of your products
  • Manage your Dell EMC sites, products, and product-level contacts using Company Administration.

Dell EMC SmartFabric OS10 User Guide Release 10.5.0

Example - BGP in a VLT topology

The following spine-leaf VLT topology runs BGP for Layer 3 communication.

Example - BGP in a VLT topology

Spine 1 configuration

  1. Configure a VLAN interface on which the BGP session has to be formed with VLT peers.
    Spine1(config)# interface vlan101
    Spine1(conf-if-vl-101)# ip address 10.0.1.1/29
    Spine1(conf-if-vl-101)# mtu 9216
    Spine1(conf-if-vl-101)# exit
  2. Configure port channel interfaces between Spine and VLT peers. Add it as part of the created VLAN.
    Spine1(config)# interface port-channel1
    Spine1(conf-if-po-1)# mtu 9216
    Spine1(conf-if-po-1)# switchport mode trunk
    Spine1(conf-if-po-1)# switchport trunk allowed vlan 101
    Spine1(conf-if-po-1)# exit
    Spine1(config)# interface ethernet1/1/1
    Spine1(conf-if-eth1/1/1)# channel-group 1 mode active
    Spine1(conf-if-eth1/1/1)# exit
    Spine1(config)# interface ethernet1/1/2
    Spine1(conf-if-eth1/1/2)# channel-group 1 mode active
    Spine1(conf-if-eth1/1/2)# exit
  3. Configure eBGP neighbor with VLT peer1 and VLT peer2.
    Spine1(config)# router bgp 65101
    Spine1(config-router-bgp-65101)# router-id 10.1.1.1
    Spine1(config-router-bgp-65101)# neighbor 10.0.1.2
    Spine1(config-router-neighbor)# remote-as 65201
    Spine1(config-router-neighbor)# no shutdown
    Spine1(config-router-neighbor)# exit
    Spine1(config-router-bgp-65101)# neighbor 10.0.1.3
    Spine1(config-router-neighbor)# remote-as 65201
    Spine1(config-router-neighbor)# no shutdown
    Spine1(config-router-neighbor)# exit

Leaf 1 configuration

  1. Configure VLT peering between VLT peer 1 and VLT peer 2.
    Leaf1(config)# interface range ethernet1/1/3-1/1/4
    Leaf1(conf-range-eth1/1/3-1/1/4)# no switchport
    Leaf1(conf-range-eth1/1/3-1/1/4)# exit
    Leaf1(config)# vlt-domain 1
    Leaf1(conf-vlt-1)# backup destination 192.168.1.2
    Leaf1(conf-vlt-1)# discovery-interface ethernet1/1/3-1/1/4
    Leaf1(conf-vlt-1)# primary-priority 1
    Leaf1(conf-vlt-1)# vlt-mac de:11:de:11:de:11
    Leaf1(conf-vlt-1)# peer-routing
    Leaf1(conf-vlt-1)# exit
  2. Configure VLAN interfaces on which BGP sessions has to be formed with Spine and ToR switches.
    Leaf1(config)# interface vlan101
    Leaf1(conf-if-vl-101)# ip address 10.0.1.2/29
    Leaf1(conf-if-vl-101)# mtu 9216
    Leaf1(conf-if-vl-101)# exit
    Leaf1(config)# interface vlan201
    Leaf1(conf-if-vl-201)# ip address 10.0.2.1/29
    Leaf1(conf-if-vl-201)# mtu 9216
    Leaf1(conf-if-vl-201)# exit
    Leaf1(config)# interface vlan301
    Leaf1(conf-if-vl-301)# ip address 10.0.3.1/29
    Leaf1(conf-if-vl-301)# mtu 9216
    Leaf1(conf-if-vl-301)# exit
  3. Configure VLT port-channel with Spine 1.
    Leaf1(config)# interface port-channel1
    Leaf1(conf-if-po-1)# mtu 9216
    Leaf1(conf-if-po-1)# switchport mode trunk
    Leaf1(conf-if-po-1)# switchport trunk allowed vlan 101
    Leaf1(conf-if-po-1)# vlt-port-channel 1
    Leaf1(conf-if-po-1)# exit
    Leaf1(config)# interface ethernet1/1/1
    Leaf1(conf-if-eth1/1/1)# channel-group 1 mode active
    Leaf1(conf-if-eth1/1/1)# exit
  4. Configure VLT port-channels with ToR 1 and ToR 2.
    Leaf1(config)# interface port-channel2
    Leaf1(conf-if-po-2)# mtu 9216
    Leaf1(conf-if-po-2)# switchport mode trunk
    Leaf1(conf-if-po-2)# switchport trunk allowed vlan 201
    Leaf1(conf-if-po-2)# vlt-port-channel 2
    Leaf1(conf-if-po-2)# exit
    Leaf1(config)# interface ethernet1/1/5
    Leaf1(conf-if-eth1/1/5)# channel-group 2 mode active
    Leaf1(conf-if-eth1/1/5)# exit
    Leaf1(config)# interface port-channel3
    Leaf1(conf-if-po-3)# mtu 9216
    Leaf1(conf-if-po-3)# switchport mode trunk
    Leaf1(conf-if-po-3)# switchport trunk allowed vlan 301
    Leaf1(conf-if-po-3)# vlt-port-channel 3
    Leaf1(conf-if-po-3)# exit
    Leaf1(config)# interface ethernet1/1/6
    Leaf1(conf-if-eth1/1/6)# channel-group 3 mode active
    Leaf1(conf-if-eth1/1/6)# exit
  5. Configure the eBGP neighbor with Spine 1 and iBGP neighbor with ToR 1 and ToR 2.
    Leaf1(config)# router bgp 65201
    Leaf1(config-router-bgp-65201)# router-id 10.2.1.1
    Leaf1(config-router-bgp-65201)# neighbor 10.0.1.1
    Leaf1(config-router-neighbor)# remote-as 65101
    Leaf1(config-router-neighbor)# no shutdown
    Leaf1(config-router-neighbor)# exit
    Leaf1(config-router-bgp-65201)# neighbor 10.0.2.3
    Leaf1(config-router-neighbor)# remote-as 65201
    Leaf1(config-router-neighbor)# route-reflector-client
    Leaf1(config-router-neighbor)# no shutdown
    Leaf1(config-router-neighbor)# address-family ipv4 unicast
    Leaf1(config-router-bgp-neighbor-af)# next-hop-self
    Leaf1(config-router-bgp-neighbor-af)# exit
    Leaf1(config-router-neighbor)# exit
    Leaf1(config-router-bgp-65201)# neighbor 10.0.3.3
    Leaf1(config-router-neighbor)# remote-as 65201
    Leaf1(config-router-neighbor)# route-reflector-client
    Leaf1(config-router-neighbor)# no shutdown
    Leaf1(config-router-neighbor)# address-family ipv4 unicast
    Leaf1(config-router-bgp-neighbor-af)# next-hop-self
    Leaf1(config-router-bgp-neighbor-af)# exit
    Leaf1(config-router-neighbor)# exit

Leaf 2 configuration

  1. Configure VLT peering between VLT peer 1 and VLT peer 2.
    Leaf2(config)# interface range ethernet1/1/3-1/1/4
    Leaf2(conf-range-eth1/1/3-1/1/4)# no switchport
    Leaf2(conf-range-eth1/1/3-1/1/4)# exit
    Leaf2(config)# vlt-domain 1
    Leaf2(conf-vlt-1)# backup destination 192.168.1.1
    Leaf2(conf-vlt-1)# discovery-interface ethernet1/1/3-1/1/4
    Leaf2(conf-vlt-1)# primary-priority 65535
    Leaf2(conf-vlt-1)# vlt-mac de:11:de:11:de:11
    Leaf2(conf-vlt-1)# peer-routing
    Leaf2(conf-vlt-1)# exit
  2. Configure VLAN interfaces on which BGP sessions has to be formed with Spine and ToR switches.
    Leaf2(config)# interface vlan101
    Leaf2(conf-if-vl-101)# ip address 10.0.1.3/29
    Leaf2(conf-if-vl-101)# mtu 9216
    Leaf2(conf-if-vl-101)# exit
    Leaf2(config)# interface vlan201
    Leaf2(conf-if-vl-201)# ip address 10.0.2.2/29
    Leaf2(conf-if-vl-201)# mtu 9216
    Leaf2(conf-if-vl-201)# exit
    Leaf2(config)# interface vlan301
    Leaf2(conf-if-vl-301)# ip address 10.0.3.2/29
    Leaf2(conf-if-vl-301)# mtu 9216
    Leaf2(conf-if-vl-301)# exit
  3. Configure VLT port-channel with Spine 1.
    Leaf2(config)# interface port-channel1
    Leaf2(conf-if-po-1)# mtu 9216
    Leaf2(conf-if-po-1)# switchport mode trunk
    Leaf2(conf-if-po-1)# switchport trunk allowed vlan 101
    Leaf2(conf-if-po-1)# vlt-port-channel 1
    Leaf2(conf-if-po-1)# exit
    Leaf2(config)# interface ethernet1/1/1
    Leaf2(conf-if-eth1/1/1)# channel-group 1 mode active
    Leaf2(conf-if-eth1/1/1)# exit
  4. Configure VLT port-channels with ToR 1 and ToR 2.
    Leaf2(config)# interface port-channel2
    Leaf2(conf-if-po-2)# mtu 9216
    Leaf2(conf-if-po-2)# switchport mode trunk
    Leaf2(conf-if-po-2)# switchport trunk allowed vlan 201
    Leaf2(conf-if-po-2)# vlt-port-channel 2
    Leaf2(conf-if-po-2)# exit
    Leaf2(config)# interface ethernet1/1/5
    Leaf2(conf-if-eth1/1/5)# channel-group 2 mode active
    Leaf2(conf-if-eth1/1/5)# exit
    Leaf2(config)# interface port-channel3
    Leaf2(conf-if-po-3)# mtu 9216
    Leaf2(conf-if-po-3)# switchport mode trunk
    Leaf2(conf-if-po-3)# switchport trunk allowed vlan 301
    Leaf2(conf-if-po-3)# vlt-port-channel 3
    Leaf2(conf-if-po-3)# exit
    Leaf2(config)# interface ethernet1/1/6
    Leaf2(conf-if-eth1/1/6)# channel-group 3 mode active
    Leaf2(conf-if-eth1/1/6)# exit
  5. Configure the eBGP neighbor with Spine 1 and iBGP neighbor with ToR 1 and ToR 2.
    Leaf2(config)# router bgp 65201
    Leaf2(config-router-bgp-65201)# router-id 10.2.1.2
    Leaf2(config-router-bgp-65201)# neighbor 10.0.1.1
    Leaf2(config-router-neighbor)# remote-as 65101
    Leaf2(config-router-neighbor)# no shutdown
    Leaf2(config-router-neighbor)# exit
    Leaf2(config-router-bgp-65201)# neighbor 10.0.2.3
    Leaf2(config-router-neighbor)# remote-as 65201
    Leaf2(config-router-neighbor)# route-reflector-client
    Leaf2(config-router-neighbor)# no shutdown
    Leaf2(config-router-neighbor)# address-family ipv4 unicast
    Leaf2(config-router-bgp-neighbor-af)# next-hop-self
    Leaf2(config-router-bgp-neighbor-af)# exit
    Leaf2(config-router-neighbor)# exit
    Leaf2(config-router-bgp-65201)# neighbor 10.0.3.3
    Leaf2(config-router-neighbor)# remote-as 65201
    Leaf2(config-router-neighbor)# route-reflector-client
    Leaf2(config-router-neighbor)# no shutdown
    Leaf2(config-router-neighbor)# address-family ipv4 unicast
    Leaf2(config-router-bgp-neighbor-af)# next-hop-self
    Leaf2(config-router-bgp-neighbor-af)# exit
    Leaf2(config-router-neighbor)# exit

ToR 1 configuration

  1. Configure VLAN interface on which the BGP session has to be formed with VLT peers.
    ToR1(config)# interface vlan201
    ToR1(conf-if-vl-201)# ip address 10.0.2.3/29
    ToR1(conf-if-vl-201)# mtu 9216
    ToR1(conf-if-vl-201)# exit
  2. Configure a port channel interface between ToR1 and VLT peers. Add it as part of the above created VLAN.
    ToR1(config)# interface port-channel2
    ToR1(conf-if-po-1)# mtu 9216
    ToR1(conf-if-po-1)# switchport mode trunk
    ToR1(conf-if-po-1)# switchport trunk allowed vlan 201
    ToR1(conf-if-po-1)# exit
    ToR1(config)# interface ethernet1/1/1
    ToR1(conf-if-eth1/1/1)# channel-group 2 mode active
    ToR1(conf-if-eth1/1/1)# exit
    ToR1(config)# interface ethernet1/1/2
    ToR1(conf-if-eth1/1/2)# channel-group 2 mode active
    ToR1(conf-if-eth1/1/2)# exit
  3. Configure the host facing VLAN and add host connected interfaces to it.
    ToR1(config)# interface vlan2001
    ToR1(conf-if-vl-2001)# ip address 172.16.1.1/24
    ToR1(conf-if-vl-2001)# mtu 9216
    ToR1(conf-if-vl-2001)# exit
    ToR1(config)# interface ethernet1/1/3
    ToR1(conf-if-eth1/1/3)# mtu 9216
    ToR1(conf-if-eth1/1/3)# switchport mode trunk
    ToR1(conf-if-eth1/1/3)# switchport trunk allowed vlan 2001
    ToR1(conf-if-eth1/1/3)# exit
  4. Configure the iBGP neighbor with VLT peers and advertise the host subnet.
    ToR1(config)# router bgp 65201
    ToR1(config-router-bgp-65201)# router-id 10.3.1.1
    ToR1(config-router-bgp-65201)# address-family ipv4 unicast
    ToR1(configure-router-bgpv4-af)# network 172.16.1.0/24
    ToR1(configure-router-bgpv4-af)# exit
    ToR1(config-router-bgp-65201)# neighbor 10.0.2.1
    ToR1(config-router-neighbor)# remote-as 65201
    ToR1(config-router-neighbor)# no shutdown
    ToR1(config-router-neighbor)# exit
    ToR1(config-router-bgp-65201)# neighbor 10.0.2.2
    ToR1(config-router-neighbor)# remote-as 65201
    ToR1(config-router-neighbor)# no shutdown
    ToR1(config-router-neighbor)# exit

ToR 2 configuration

  1. Configure a VLAN interface on which the BGP session has to be formed with VLT peers.
    ToR2(config)# interface vlan301
    ToR2(conf-if-vl-201)# mtu 9216
    ToR2(conf-if-vl-201)# ip address 10.0.3.3/29
    ToR2(conf-if-vl-201)# exit
  2. Configure a port channel interface between ToR2 and VLT peers. Add it as part of the above created VLAN.
    ToR2(config)# interface port-channel3
    ToR2(conf-if-po-1)# mtu 9216
    ToR2(conf-if-po-1)# switchport mode trunk
    ToR2(conf-if-po-1)# switchport trunk allowed vlan 301
    ToR2(conf-if-po-1)# exit
    ToR2(config)# interface ethernet1/1/1
    ToR2(conf-if-eth1/1/1)# channel-group 3 mode active
    ToR2(conf-if-eth1/1/1)# exit
    ToR2(config)# interface ethernet1/1/2
    ToR2(conf-if-eth1/1/2)# channel-group 3 mode active
    ToR2(conf-if-eth1/1/2)# exit
  3. Configure the host facing VLAN and add host connected interfaces to it.
    ToR2(config)# interface vlan3001
    ToR2(conf-if-vl-2001)# mtu 9216
    ToR2(conf-if-vl-2001)# ip address 172.16.2.1/24
    ToR2(conf-if-vl-2001)# exit
    ToR2(config)# interface ethernet1/1/3
    ToR2(conf-if-eth1/1/3)# mtu 9216
    ToR2(conf-if-eth1/1/3)# switchport mode trunk
    ToR2(conf-if-eth1/1/3)# switchport trunk allowed vlan 3001
    ToR2(conf-if-eth1/1/3)# exit
  4. Configure the iBGP neighbor with VLT peers and advertise the host subnet.
    ToR2(config)# router bgp 65201
    ToR2(config-router-bgp-65201)# router-id 10.3.1.2
    ToR2(config-router-bgp-65201)# address-family ipv4 unicast
    ToR2(configure-router-bgpv4-af)# network 172.16.2.0/24
    ToR2(configure-router-bgpv4-af)# exit
    ToR2(config-router-bgp-65201)# neighbor 10.0.2.1
    ToR2(config-router-neighbor)# remote-as 65201
    ToR2(config-router-neighbor)# no shutdown
    ToR2(config-router-neighbor)# exit
    ToR2(config-router-bgp-65201)# neighbor 10.0.2.2
    ToR2(config-router-neighbor)# remote-as 65201
    ToR2(config-router-neighbor)# no shutdown
    ToR2(config-router-neighbor)# exit

Rate this content

Accurate
Useful
Easy to understand
Was this article helpful?
0/3000 characters
  Please provide ratings (1-5 stars).
  Please provide ratings (1-5 stars).
  Please provide ratings (1-5 stars).
  Please select whether the article was helpful or not.
  Comments cannot contain these special characters: <>()\