Skip to main content
  • Place orders quickly and easily
  • View orders and track your shipping status
  • Create and access a list of your products
  • Manage your Dell EMC sites, products, and product-level contacts using Company Administration.

Dell EMC SmartFabric OS10 User Guide Release 10.5.0

Configure multi-hop FSB

The following example shows a simple multi-hop FSB setup. CNA-2 and CNA-3 shown in this topology are for illustrative purposes only. The following example does not include CNA-2 and CNA-3 configurations.

Ensure that the access and core FSB switches are running in FSB mode.

multi-hop FSB

To configure multi-hop FSB:

  1. Configure the L2 switch.
    1. Disable flow control on the interfaces connected to CNA-4 and FSB1.
      L2switch(config)# interface ethernet 1/1/32
      L2switch(conf-if-eth1/1/32)# no flowcontrol receive
      L2switch(conf-if-eth1/1/32)# no flowcontrol transmit
      
      L2switch(config)# interface ethernet 1/1/5
      L2switch(conf-if-eth1/1/5)# no flowcontrol receive
      L2switch(conf-if-eth1/1/5)# no flowcontrol transmit
    2. Enable DCBX.
      L2switch(config)# dcbx enable
    3. Create a VLAN for FCoE traffic to pass through.
      L2switch(config)# interface vlan 777
    4. Create class-maps.
      L2switch(config)# class-map type network-qos c3
      L2switch(config-cmap-nqos)# match qos-group 3
      L2switch(config)# class-map type queuing q0
      L2switch(config-cmap-queuing)# match queue 0
      L2switch(config-cmap-queuing)# exit
      L2switch(config)# class-map type queuing q3
      L2switch(config-cmap-queuing)# match queue 3
      L2switch(config-cmap-queuing)# exit
      
    5. Create policy-maps.
      L2switch# configure terminal
      L2switch(config)# policy-map type network-qos nqpolicy
      L2switch(config-pmap-network-qos)# class c3
      L2switch(config-pmap-c-nqos)# pause
      L2switch(config-pmap-c-nqos)# pfc-cos 3
      L2switch(config)# policy-map type queuing ets_policy
      L2switch(config-pmap-queuing)# class q0
      L2switch(config-pmap-c-que)# bandwidth percent 30
      L2switch(config-pmap-c-que)# class q3
      L2switch(config-pmap-c-que)# bandwidth percent 70
    6. Create a qos-map.
      L2switch(config)# qos-map traffic-class tc-q-map1
      L2switch(config-qos-map)# queue 3 qos-group 3
      L2switch(config-qos-map)# queue 0 qos-group 0-2,4-7
    7. Apply the QoS configurations on CNA-4 and FSB1 connected interfaces.
      L2switch(config)# interface ethernet 1/1/32
      L2switch(conf-if-eth1/1/32)# priority-flow-control mode on
      L2switch(conf-if-eth1/1/32)# ets mode on
      L2switch(conf-if-eth1/1/32)# trust-map dot1p default
      L2switch(conf-if-eth1/1/32)# qos-map traffic-class tc-q-map1
      L2switch(conf-if-eth1/1/32)# service-policy input type network-qos nqpolicy
      L2switch(conf-if-eth1/1/32)# service-policy output type queuing ets_policy
      
      L2switch(config)# interface ethernet 1/1/5
      L2switch(conf-if-eth1/1/5)# priority-flow-control mode on
      L2switch(conf-if-eth1/1/5)# ets mode on
      L2switch(conf-if-eth1/1/5)# trust-map dot1p default
      L2switch(conf-if-eth1/1/5)# qos-map traffic-class tc-q-map1
      L2switch(conf-if-eth1/1/5)# service-policy input type network-qos nqpolicy
      L2switch(conf-if-eth1/1/5)# service-policy output type queuing ets_policy
      
    8. Configure VLAN on CNA-4 and FSB1 connected interfaces.
      L2switch(config)# interface ethernet 1/1/32
      L2switch(conf-if-eth1/1/32)# switchport mode trunk
      L2switch(conf-if-eth1/1/32)# switchport trunk allowed vlan 777
      
      L2switch(config)# interface ethernet 1/1/5
      L2switch(conf-if-eth1/1/5)# switchport mode trunk
      L2switch(conf-if-eth1/1/5)# switchport trunk allowed vlan 777
  2. Configure the access FSB, FSB1. This example describes
    1. Disable flow control on the interfaces connected to CNA1, L2 switch, and FSB2.
      FSB1(config)# interface ethernet 1/1/31
      FSB1(conf-if-eth1/1/31)# no flowcontrol receive
      FSB1(conf-if-eth1/1/31)# no flowcontrol transmit
      
      FSB1(config)# interface ethernet 1/1/5
      FSB1(conf-if-eth1/1/5)# no flowcontrol receive
      FSB1(conf-if-eth1/1/5)# no flowcontrol transmit
      
      FSB1(config)# interface ethernet 1/1/2
      FSB1(conf-if-eth1/1/2)# no flowcontrol receive
      FSB1(conf-if-eth1/1/2)# no flowcontrol transmit
    2. Enable FIP snooping with cvl option.
      FSB1(config)# feature fip-snooping with-cvl
      
    3. Enable DCBX.
      FSB1(config)# dcbx enable
    4. Create an FCoE VLAN and configure FIP snooping on the FCoE VLAN.
      FSB1(config)# interface vlan 777
      FSB1(conf-if-vl-777)# fip-snooping enable
    5. Create class-maps.
      FSB1(config)# class-map type network-qos c3
      FSB1(config-cmap-nqos)# match qos-group 3
      FSB1(config)# class-map type queuing q0
      FSB1(config-cmap-queuing)# match queue 0
      FSB1(config-cmap-queuing)# exit
      FSB1(config)# class-map type queuing q3
      FSB1(config-cmap-queuing)# match queue 3
      FSB1(config-cmap-queuing)# exit
      
    6. Create policy-maps.
      FSB1(config)# policy-map type network-qos nqpolicy
      FSB1(config-pmap-network-qos)# class c3
      FSB1(config-pmap-c-nqos)# pause
      FSB1(config-pmap-c-nqos)# pfc-cos 3
      FSB1(config)# policy-map type queuing ets_policy
      FSB1(config-pmap-queuing)# class q0
      FSB1(config-pmap-c-que)# bandwidth percent 30
      FSB1(config-pmap-c-que)# class q3
      FSB1(config-pmap-c-que)# bandwidth percent 70
    7. Create a qos-map.
      FSB1(config)# qos-map traffic-class tc-q-map1
      FSB1(config-qos-map)# queue 3 qos-group 3
      FSB1(config-qos-map)# queue 0 qos-group 0-2,4-7
    8. Apply the QoS configurations on CNA1, L2 switch, and FSB2 connected interfaces.
      FSB1(config)# interface ethernet 1/1/31
      FSB1(conf-if-eth1/1/31)# priority-flow-control mode on
      FSB1(conf-if-eth1/1/31)# ets mode on
      FSB1(conf-if-eth1/1/31)# trust-map dot1p default
      FSB1(conf-if-eth1/1/31)# qos-map traffic-class tc-q-map1
      FSB1(conf-if-eth1/1/31)# service-policy input type network-qos nqpolicy
      FSB1(conf-if-eth1/1/31)# service-policy output type queuing ets_policy
      
      FSB1(config)# interface ethernet 1/1/5
      FSB1(conf-if-eth1/1/5)# priority-flow-control mode on
      FSB1(conf-if-eth1/1/5)# ets mode on
      FSB1(conf-if-eth1/1/5)# trust-map dot1p default
      FSB1(conf-if-eth1/1/5)# qos-map traffic-class tc-q-map1
      FSB1(conf-if-eth1/1/5)# service-policy input type network-qos nqpolicy
      FSB1(conf-if-eth1/1/5)# service-policy output type queuing ets_policy
      
      FSB1(config)# interface ethernet 1/1/2
      FSB1(conf-if-eth1/1/2)# priority-flow-control mode on
      FSB1(conf-if-eth1/1/2)# ets mode on
      FSB1(conf-if-eth1/1/2)# trust-map dot1p default
      FSB1(conf-if-eth1/1/2)# qos-map traffic-class tc-q-map1
      FSB1(conf-if-eth1/1/2)# service-policy input type network-qos nqpolicy
      FSB1(conf-if-eth1/1/2)# service-policy output type queuing ets_policy
      
    9. Configure VLAN on CNA1, L2 switch, and FSB2 connected interfaces.
      FSB1(config)# interface ethernet 1/1/31
      FSB1(conf-if-eth1/1/31)# switchport mode trunk
      FSB1(conf-if-eth1/1/31)# switchport trunk allowed vlan 777
      
      FSB1(config)# interface ethernet 1/1/5
      FSB1(conf-if-eth1/1/5)# switchport mode trunk
      FSB1(conf-if-eth1/1/5)# switchport trunk allowed vlan 777
      
      FSB1(config)# interface ethernet 1/1/2
      FSB1(conf-if-eth1/1/2)# switchport mode trunk
      FSB1(conf-if-eth1/1/2)# switchport trunk allowed vlan 777
    10. Configure FIP snooping port mode on the L2 DCBX switch connected interface and FSB2 connected interface. The default port mode is ENode. Hence, CNA1-connected interface does not require additional configuration.

      On the L2 DCBX switch-connected interface:

      FSB1(config)# interface ethernet 1/1/5
      FSB1(conf-if-eth1/1/5)# fip-snooping port-mode enode-transit

      On the FSB-connected interfaces:

      FSB1(config)# interface ethernet 1/1/2
      FSB1(conf-if-eth1/1/2)# fip-snooping port-mode fcf
  3. Configure the core FSB, FSB2.
    1. Disable flow control on the interfaces connected to FSB1 and FCF.
      FSB2(config)# interface ethernet 1/1/2
      FSB2(conf-if-eth1/1/2)# no flowcontrol receive
      FSB2(conf-if-eth1/1/2)# no flowcontrol transmit
      
      FSB2(config)# interface ethernet 1/1/13
      FSB2(conf-if-eth1/1/13)# no flowcontrol receive
      FSB2(conf-if-eth1/1/13)# no flowcontrol transmit
    2. Enable FIP snooping with cvl option.
      FSB2(config)# feature fip-snooping with-cvl
    3. Enable DCBX.
      FSB2(config)# dcbx enable
    4. Create an FCoE VLAN and configure FIP snooping on the FCoE VLAN.
      FSB2(config)# interface vlan 777
      FSB2(conf-if-vl-777)# fip-snooping enable
    5. Create class-maps.
      FSB2(config)# class-map type network-qos c3
      FSB2(config-cmap-nqos)# match qos-group 3
      FSB2(config)# class-map type queuing q0
      FSB2(config-cmap-queuing)# match queue 0
      FSB2(config-cmap-queuing)# exit
      FSB2(config)# class-map type queuing q3
      FSB2(config-cmap-queuing)# match queue 3
      FSB2(config-cmap-queuing)# exit
      
    6. Create policy-maps.
      FSB2(config)# policy-map type network-qos nqpolicy
      FSB2(config-pmap-network-qos)# class c3
      FSB2(config-pmap-c-nqos)# pause
      FSB2(config-pmap-c-nqos)# pfc-cos 3
      FSB2(config)# policy-map type queuing ets_policy
      FSB2(config-pmap-queuing)# class q0
      FSB2(config-pmap-c-que)# bandwidth percent 30
      FSB2(config-pmap-c-que)# class q3
      FSB2(config-pmap-c-que)# bandwidth percent 70
    7. Create a qos-map.
      FSB2(config)# qos-map traffic-class tc-q-map1
      FSB2(config-qos-map)# queue 3 qos-group 3
      FSB2(config-qos-map)# queue 0 qos-group 0-2,4-7
    8. Apply the QoS configurations on FSB1 and FCF connected interfaces.
      FSB2(config)# interface ethernet 1/1/2
      FSB2(conf-if-eth1/1/2)# priority-flow-control mode on
      FSB2(conf-if-eth1/1/2)# ets mode on
      FSB2(conf-if-eth1/1/2)# trust-map dot1p default
      FSB2(conf-if-eth1/1/2)# qos-map traffic-class tc-q-map1
      FSB2(conf-if-eth1/1/2)# service-policy input type network-qos nqpolicy
      FSB2(conf-if-eth1/1/2)# service-policy output type queuing ets_policy
      
      FSB2(config)# interface ethernet 1/1/13
      FSB2(conf-if-eth1/1/13)# priority-flow-control mode on
      FSB2(conf-if-eth1/1/13)# ets mode on
      FSB2(conf-if-eth1/1/13)# trust-map dot1p default
      FSB2(conf-if-eth1/1/13)# qos-map traffic-class tc-q-map1
      FSB2(conf-if-eth1/1/13)# service-policy input type network-qos nqpolicy
      FSB2(conf-if-eth1/1/13)# service-policy output type queuing ets_policy
    9. Configure VLAN on FSB1 and FCF connected interfaces.
      FSB2(config)# interface ethernet 1/1/2
      FSB2(conf-if-eth1/1/2)# switchport mode trunk
      FSB2(conf-if-eth1/1/2)# switchport trunk allowed vlan 777
      
      FSB2(config)# interface ethernet 1/1/13
      FSB2(conf-if-eth1/1/13)# switchport mode trunk
      FSB2(conf-if-eth1/1/13)# switchport trunk allowed vlan 777
    10. Configure FIP snooping port mode on FSB1 and FCF connected interfaces.

      On the FSB1-connected interface:

      FSB2(config)# interface ethernet 1/1/2
      FSB2(conf-if-eth1/1/2)# fip-snooping port-mode enode-transit

      On the FCF-connected interface:

      FSB2(config)# interface ethernet 1/1/13
      FSB2(conf-if-eth1/1/13)# fip-snooping port-mode fcf-transit
  4. Configure the FCF. The following configuration assumes that the FCF is in F-Port mode.
    1. Disable flow control on the interface connected to FSB2.
      FCF(config)# interface ethernet 1/1/13
      FCF(conf-if-eth1/1/13)# no flowcontrol receive
      FCF(conf-if-eth1/1/13)# no flowcontrol transmit
    2. Enable Fiber Channel F-Port mode globally.
      FCF(config)# feature fc domain-id 2
    3. Create zones.
      FCF(config)# fc zone zoneA
      FCF(config-fc-zone-zoneA)# member wwn 20:01:f4:e9:d4:a4:7d:c3
      FCF(config-fc-zone-zoneA)# member wwn 21:00:00:24:ff:7c:ae:0e
    4. Create zoneset.
      FCF(config)# fc zoneset zonesetA
      FCF(conf-fc-zoneset-set)# member zoneA
    5. Create a vfabric VLAN.
      FCF(config)# interface vlan 777
    6. Create vfabric and activate the zoneset.
      FCF(config)# vfabric 2
      FCF(conf-vfabric-2)# vlan 777
      FCF(conf-vfabric-2)# fcoe fcmap 0xEFC00
      FCF(conf-vfabric-2)# zoneset activate zonesetA
    7. Enable DCBX.
      FCF(config)# dcbx enable
    8. Create class maps and policy maps.
      FCF(config)# class-map type network-qos c3
      FCF(config-cmap-nqos)# match qos-group 3
      FCF(config)# class-map type queuing q0
      FCF(config-cmap-queuing)# match queue 0
      FCF(config-cmap-queuing)# exit
      FCF(config)# class-map type queuing q3
      FCF(config-cmap-queuing)# match queue 3
      FCF(config-cmap-queuing)# exit
      
      FCF(config)# policy-map type network-qos nqpolicy
      FCF(config-pmap-network-qos)# class c3
      FCF(config-pmap-c-nqos)# pause
      FCF(config-pmap-c-nqos)# pfc-cos 3
      FCF(config)# policy-map type queuing ets_policy
      FCF(config-pmap-queuing)# class q0
      FCF(config-pmap-c-que)# bandwidth percent 30
      FCF(config-pmap-c-que)# class q3
      FCF(config-pmap-c-que)# bandwidth percent 70
    9. Create a qos-map.
      FCF(config)# qos-map traffic-class tc-q-map1
      FCF(config-qos-map)# queue 3 qos-group 3
      FCF(config-qos-map)# queue 0 qos-group 0-2,4-7
    10. Apply vfabric on FSB2 and target connected interfaces.
      FCF(config)# interface ethernet 1/1/13 
      FCF(conf-if-eth1/1/13)# no shutdown
      FCF(conf-if-eth1/1/13)# switchport access vlan 1
      FCF(conf-if-eth1/1/13)# vfabric 2
      FCF(config)# interface fibrechannel 1/1/3
      FCF(conf-if-fc1/1/3)# description target_connected_port
      FCF(conf-if-fc1/1/3)# no shutdown
      FCF(conf-if-fc1/1/3)# vfabric 2
    11. Apply QoS configurations on the interface connected to FSB2.
      FCF(config)# interface ethernet 1/1/13
      FCF(conf-if-eth1/1/13)# priority-flow-control mode on
      FCF(conf-if-eth1/1/13)# ets mode on
      FCF(conf-if-eth1/1/13)# trust-map dot1p default
      FCF(conf-if-eth1/1/13)# qos-map traffic-class tc-q-map1
      FCF(conf-if-eth1/1/13)# service-policy input type network-qos nqpolicy
      FCF(conf-if-eth1/1/13)# service-policy output type queuing ets_policy
      

Rate this content

Accurate
Useful
Easy to understand
Was this article helpful?
0/3000 characters
  Please provide ratings (1-5 stars).
  Please provide ratings (1-5 stars).
  Please provide ratings (1-5 stars).
  Please select whether the article was helpful or not.
  Comments cannot contain these special characters: <>()\