Skip to main content
  • Place orders quickly and easily
  • View orders and track your shipping status
  • Create and access a list of your products
  • Manage your Dell EMC sites, products, and product-level contacts using Company Administration.

Dell EMC SmartFabric OS10 User Guide Release 10.5.0

Example - Three-tier CLOS topology with eBGP

This section provides a sample three-tier topology with external BGP.

Example - Three-tier CLOS topology with eBGP

Spine 1 configuration

  1. Configure an IP address on leaf-facing interfaces.
    Spine1(config)# interface ethernet1/1/1
    Spine1(conf-if-eth1/1/1)# description Spine1-Leaf1
    Spine1(conf-if-eth1/1/1)# no switchport
    Spine1(conf-if-eth1/1/1)# mtu 9216
    Spine1(conf-if-eth1/1/1)# ip address 10.1.1.0/31
    Spine1(conf-if-eth1/1/1)# exit
    Spine1(config)# interface ethernet1/1/2
    Spine1(conf-if-eth1/1/2)# description Spine1-Leaf2
    Spine1(conf-if-eth1/1/2)# no switchport
    Spine1(conf-if-eth1/1/2)# mtu 9216
    Spine1(conf-if-eth1/1/2)# ip address 10.1.1.2/31
    Spine1(conf-if-eth1/1/2)# exit
    Spine1(config)# interface ethernet1/1/3
    Spine1(conf-if-eth1/1/3)# description Spine1-Leaf3
    Spine1(conf-if-eth1/1/3)# no switchport
    Spine1(conf-if-eth1/1/3)# mtu 9216
    Spine1(conf-if-eth1/1/3)# ip address 10.1.2.0/31
    Spine1(conf-if-eth1/1/3)# exit
    Spine1(config)# interface ethernet1/1/4
    Spine1(conf-if-eth1/1/4)# description Spine1-Leaf4
    Spine1(conf-if-eth1/1/4)# no switchport
    Spine1(conf-if-eth1/1/4)# mtu 9216
    Spine1(conf-if-eth1/1/4)# ip address 10.1.2.2/31
    Spine1(conf-if-eth1/1/4)# exit
  2. Configure BGP neighbors. This example uses passive peering which simplifies neighbor configuration.
    Spine1(config)# router bgp 65101
    Spine1(config-router-bgp-65101)# router-id 10.0.0.1
    Spine1(config-router-bgp-65101)# template passive_v4_pod1
    Spine1(config-router-template)# remote-as 65201
    Spine1(config-router-template)# listen 10.1.1.0/24
    Spine1(config-router-template)# exit
    Spine1(config-router-bgp-65101)# template passive_v4_pod2
    Spine1(config-router-template)# remote-as 65202
    Spine1(config-router-template)# listen 10.1.2.0/24
    Spine1(config-router-template)# exit

Spine 2 configuration

  1. Configure an IP address on leaf-facing interfaces.
    Spine2(config)# interface ethernet1/1/1
    Spine2(conf-if-eth1/1/1)# description Spine2-Leaf1
    Spine2(conf-if-eth1/1/1)# no switchport
    Spine2(conf-if-eth1/1/1)# mtu 9216
    Spine2(conf-if-eth1/1/1)# ip address 10.2.1.0/31
    Spine2(conf-if-eth1/1/1)# exit
    Spine2(config)# interface ethernet1/1/2
    Spine2(conf-if-eth1/1/2)# description Spine2-Leaf2
    Spine2(conf-if-eth1/1/2)# no switchport
    Spine2(conf-if-eth1/1/2)# mtu 9216
    Spine2(conf-if-eth1/1/2)# ip address 10.2.1.2/31
    Spine2(conf-if-eth1/1/2)# exit
    Spine2(config)# interface ethernet1/1/3
    Spine2(conf-if-eth1/1/3)# description Spine2-Leaf3
    Spine2(conf-if-eth1/1/3)# no switchport
    Spine2(conf-if-eth1/1/3)# mtu 9216
    Spine2(conf-if-eth1/1/3)# ip address 10.2.2.0/31
    Spine2(conf-if-eth1/1/3)# exit
    Spine2(config)# interface ethernet1/1/4
    Spine2(conf-if-eth1/1/4)# description Spine2-Leaf4
    Spine2(conf-if-eth1/1/4)# no switchport
    Spine2(conf-if-eth1/1/4)# mtu 9216
    Spine2(conf-if-eth1/1/4)# ip address 10.2.2.2/31
    Spine2(conf-if-eth1/1/4)# exit
  2. Configure BGP neighbors. This example uses passive peering which simplifies neighbor configuration.
    Spine2(config)# router bgp 65101
    Spine2(config-router-bgp-65101)# router-id 10.0.0.2
    Spine2(config-router-bgp-65101)# template passive_v4_pod1
    Spine2(config-router-template)# remote-as 65201
    Spine2(config-router-template)# listen 10.2.1.0/24
    Spine2(config-router-template)# exit
    Spine2(config-router-bgp-65101)# template passive_v4_pod2
    Spine2(config-router-template)# remote-as 65202
    Spine2(config-router-template)# listen 10.2.2.0/24
    Spine2(config-router-template)# exit

Leaf 1 configuration

  1. Configure an IP address on spine-facing interfaces.
    Leaf1(config)# interface ethernet1/1/1
    Leaf1(conf-if-eth1/1/1)# description Leaf1-Spine1
    Leaf1(conf-if-eth1/1/1)# no switchport
    Leaf1(conf-if-eth1/1/1)# mtu 9216
    Leaf1(conf-if-eth1/1/1)# ip address 10.1.1.1/31
    Leaf1(conf-if-eth1/1/1)# exit
    Leaf1(config)# interface ethernet1/1/2
    Leaf1(conf-if-eth1/1/2)# description Leaf1-Spine2
    Leaf1(conf-if-eth1/1/2)# no switchport
    Leaf1(conf-if-eth1/1/2)# mtu 9216
    Leaf1(conf-if-eth1/1/2)# ip address 10.2.1.1/31
    Leaf1(conf-if-eth1/1/2)# exit
  2. Configure an IP address on ToR facing interfaces.
    Leaf1(config)# interface ethernet1/1/3
    Leaf1(conf-if-eth1/1/1)# description Leaf1-ToR1
    Leaf1(conf-if-eth1/1/1)# no switchport
    Leaf1(conf-if-eth1/1/1)# mtu 9216
    Leaf1(conf-if-eth1/1/1)# ip address 10.3.1.0/31
    Leaf1(conf-if-eth1/1/1)# exit
  3. Configure BGP neighbors.
    Leaf1(config)# router bgp 65201
    Leaf1(config-router-bgp-65201)# router-id 10.0.1.1
    Leaf1(config-router-bgp-65201)# neighbor 10.1.1.0
    Leaf1(config-router-neighbor)# remote-as 65101
    Leaf1(config-router-neighbor)# no shutdown
    Leaf1(config-router-neighbor)# exit
    Leaf1(config-router-bgp-65201)# neighbor 10.2.1.0
    Leaf1(config-router-neighbor)# remote-as 65101
    Leaf1(config-router-neighbor)# no shutdown
    Leaf1(config-router-neighbor)# exit
    Leaf1(config-router-bgp-65201)# neighbor 10.3.1.1
    Leaf1(config-router-neighbor)# remote-as 65301
    Leaf1(config-router-neighbor)# no shutdown
    Leaf1(config-router-neighbor)# exit
    

Leaf 2 configuration

  1. Configure an IP address on spine-facing interfaces.
    Leaf2(config)# interface ethernet1/1/1
    Leaf2(conf-if-eth1/1/1)# description Leaf2-Spine1
    Leaf2(conf-if-eth1/1/1)# no switchport
    Leaf2(conf-if-eth1/1/1)# mtu 9216
    Leaf2(conf-if-eth1/1/1)# ip address 10.1.1.3/31
    Leaf2(conf-if-eth1/1/1)# exit
    Leaf2(config)# interface ethernet1/1/2
    Leaf2(conf-if-eth1/1/2)# description Leaf2-Spine2
    Leaf2(conf-if-eth1/1/2)# no switchport
    Leaf2(conf-if-eth1/1/2)# mtu 9216
    Leaf2(conf-if-eth1/1/2)# ip address 10.2.1.3/31
    Leaf2(conf-if-eth1/1/2)# exit
  2. Configure an IP address on ToR-facing interfaces.
    Leaf2(config)# interface ethernet1/1/3
    Leaf2(conf-if-eth1/1/1)# description Leaf2-ToR1
    Leaf2(conf-if-eth1/1/1)# no switchport
    Leaf2(conf-if-eth1/1/1)# mtu 9216
    Leaf2(conf-if-eth1/1/1)# ip address 10.4.1.0/31
    Leaf2(conf-if-eth1/1/1)# exit
  3. Configure BGP neighbors.
    Leaf2(config)# router bgp 65201
    Leaf2(config-router-bgp-65201)# router-id 10.0.1.2
    Leaf2(config-router-bgp-65201)# neighbor 10.1.1.2
    Leaf2(config-router-neighbor)# remote-as 65101
    Leaf2(config-router-neighbor)# no shutdown
    Leaf2(config-router-neighbor)# exit
    Leaf2(config-router-bgp-65201)# neighbor 10.2.1.2
    Leaf2(config-router-neighbor)# remote-as 65101
    Leaf2(config-router-neighbor)# no shutdown
    Leaf2(config-router-neighbor)# exit
    Leaf2(config-router-bgp-65201)# neighbor 10.4.1.1
    Leaf2(config-router-neighbor)# remote-as 65301
    Leaf2(config-router-neighbor)# no shutdown
    Leaf2(config-router-neighbor)# exit

Leaf 3 configuration

  1. Configure an IP address on spine-facing interfaces.
    Leaf3(config)# interface ethernet1/1/1
    Leaf3(conf-if-eth1/1/1)# description Leaf3-Spine1
    Leaf3(conf-if-eth1/1/1)# no switchport
    Leaf3(conf-if-eth1/1/1)# mtu 9216
    Leaf3(conf-if-eth1/1/1)# ip address 10.1.2.1/31
    Leaf3(conf-if-eth1/1/1)# exit
    Leaf3(config)# interface ethernet1/1/2
    Leaf3(conf-if-eth1/1/2)# description Leaf3-Spine2
    Leaf3(conf-if-eth1/1/2)# no switchport
    Leaf3(conf-if-eth1/1/2)# mtu 9216
    Leaf3(conf-if-eth1/1/2)# ip address 10.2.2.1/31
    Leaf3(conf-if-eth1/1/2)# exit
  2. Configure an IP address on ToR-facing interfaces.
    Leaf3(config)# interface ethernet1/1/3
    Leaf3(conf-if-eth1/1/3)# description Leaf3-ToR2
    Leaf3(conf-if-eth1/1/3)# no switchport
    Leaf3(conf-if-eth1/1/3)# mtu 9216
    Leaf3(conf-if-eth1/1/3)# ip address 10.5.1.0/31
    Leaf3(conf-if-eth1/1/3)# exit
  3. Configure BGP neighbors.
    Leaf3(config)# router bgp 65202
    Leaf3(config-router-bgp-65202)# router-id 10.0.1.3
    Leaf3(config-router-bgp-65202)# neighbor 10.1.2.0
    Leaf3(config-router-neighbor)# remote-as 65101
    Leaf3(config-router-neighbor)# no shutdown
    Leaf3(config-router-neighbor)# exit
    Leaf3(config-router-bgp-65202)# neighbor 10.2.2.0
    Leaf3(config-router-neighbor)# remote-as 65101
    Leaf3(config-router-neighbor)# no shutdown
    Leaf3(config-router-neighbor)# exit
    Leaf3(config-router-bgp-65202)# neighbor 10.5.1.1
    Leaf3(config-router-neighbor)# remote-as 65302
    Leaf3(config-router-neighbor)# no shutdown
    Leaf3(config-router-neighbor)# exit

Leaf 4 configuration

  1. Configure an IP address on spine-facing interfaces.
    Leaf4(config)# interface ethernet1/1/1
    Leaf4(conf-if-eth1/1/1)# description Leaf4-Spine1
    Leaf4(conf-if-eth1/1/1)# no switchport
    Leaf4(conf-if-eth1/1/1)# mtu 9216
    Leaf4(conf-if-eth1/1/1)# ip address 10.1.2.3/31
    Leaf4(conf-if-eth1/1/1)# exit
    Leaf4(config)# interface ethernet1/1/2
    Leaf4(conf-if-eth1/1/2)# description Leaf4-Spine2
    Leaf4(conf-if-eth1/1/2)# no switchport
    Leaf4(conf-if-eth1/1/2)# mtu 9216
    Leaf4(conf-if-eth1/1/2)# ip address 10.2.2.3/31
    Leaf4(conf-if-eth1/1/2)# exit
  2. Configure an IP address on ToR-facing interfaces.
    Leaf4(config)# interface ethernet1/1/3
    Leaf4(conf-if-eth1/1/3)# description Leaf4-ToR2
    Leaf4(conf-if-eth1/1/3)# no switchport
    Leaf4(conf-if-eth1/1/3)# mtu 9216
    Leaf4(conf-if-eth1/1/3)# ip address 10.6.1.0/31
    Leaf4(conf-if-eth1/1/3)# exit
  3. Configure BGP neighbors.
    Leaf4(config)# router bgp 65202
    Leaf4(config-router-bgp-65202)# router-id 10.0.1.4
    Leaf4(config-router-bgp-65202)# neighbor 10.1.2.2
    Leaf4(config-router-neighbor)# remote-as 65101
    Leaf4(config-router-neighbor)# no shutdown
    Leaf4(config-router-neighbor)# exit
    Leaf4(config-router-bgp-65202)# neighbor 10.2.2.2
    Leaf4(config-router-neighbor)# remote-as 65101
    Leaf4(config-router-neighbor)# no shutdown
    Leaf4(config-router-neighbor)# exit
    Leaf4(config-router-bgp-65202)# neighbor 10.6.1.1
    Leaf4(config-router-neighbor)# remote-as 65302
    Leaf4(config-router-neighbor)# no shutdown
    Leaf4(config-router-neighbor)# exit

ToR 1 configuration

  1. Configure an IP address on leaf-facing interfaces.
    ToR1(config)# interface ethernet1/1/1
    ToR1(conf-if-eth1/1/1)# description ToR1-Leaf1
    ToR1(conf-if-eth1/1/1)# no switchport
    ToR1(conf-if-eth1/1/1)# mtu 9216
    ToR1(conf-if-eth1/1/1)# ip address 10.3.1.1/31
    ToR1(conf-if-eth1/1/1)# exit
    ToR1(config)# interface ethernet1/1/2
    ToR1(conf-if-eth1/1/2)# description ToR1-Leaf2
    ToR1(conf-if-eth1/1/2)# no switchport
    ToR1(conf-if-eth1/1/2)# mtu 9216
    ToR1(conf-if-eth1/1/2)# ip address 10.4.1.1/31
    ToR1(conf-if-eth1/1/2)# exit
  2. Configure a VLAN interface and a VLAN member for the end hosts.
    ToR1(config)# interface vlan 1001
    ToR1(conf-if-vl-1001)# ip address 172.16.1.1/24
    ToR1(conf-if-vl-1001)# mtu 9216
    ToR1(conf-if-vl-1001)# exit
    ToR1(config)# interface ethernet1/1/3
    ToR1(conf-if-eth1/1/3)# description ToR1-Hosts
    ToR1(conf-if-eth1/1/3)# mtu 9216
    ToR1(conf-if-eth1/1/3)# switchport mode trunk
    ToR1(conf-if-eth1/1/3)# switchport trunk allowed vlan 1001
    ToR1(conf-if-eth1/1/3)# exit
  3. Configure BGP neighbors, and advertise the host subnet.
    ToR1(config)# router bgp 65301
    ToR1(config-router-bgp-65301)# router-id 10.0.2.1
    ToR1(config-router-bgp-65301)# address-family ipv4 unicast
    ToR1(configure-router-bgpv4-af)# network 172.16.1.0/24
    ToR1(configure-router-bgpv4-af)# exit
    ToR1(config-router-bgp-65301)# neighbor 10.3.1.0
    ToR1(config-router-neighbor)# remote-as 65201
    ToR1(config-router-neighbor)# no shutdown
    ToR1(config-router-neighbor)# exit
    ToR1(config-router-bgp-65301)# neighbor 10.4.1.0
    ToR1(config-router-neighbor)# remote-as 65201
    ToR1(config-router-neighbor)# no shutdown
    ToR1(config-router-neighbor)# exit

ToR 2 configuration

  1. Configure an IP address on leaf-facing interfaces.
    ToR2(config)# interface ethernet1/1/1
    ToR2(conf-if-eth1/1/1)# description ToR2-Leaf3
    ToR2(conf-if-eth1/1/1)# no switchport
    ToR2(conf-if-eth1/1/1)# mtu 9216
    ToR2(conf-if-eth1/1/1)# ip address 10.5.1.1/31
    ToR2(conf-if-eth1/1/1)# exit
    ToR2(config)# interface ethernet1/1/2
    ToR2(conf-if-eth1/1/2)# description ToR2-Leaf4
    ToR2(conf-if-eth1/1/2)# no switchport
    ToR2(conf-if-eth1/1/2)# mtu 9216
    ToR2(conf-if-eth1/1/2)# ip address 10.6.1.1/31
    ToR2(conf-if-eth1/1/2)# exit
  2. Configure a VLAN interface and a VLAN member for end devices.
    ToR2(config)# interface vlan 2001
    ToR2(conf-if-vl-2001)# ip address 172.16.2.1/24
    ToR2(conf-if-vl-2001)# mtu 9216
    ToR2(conf-if-vl-2001)# exit
    ToR2(config)# interface ethernet1/1/3
    ToR2(conf-if-eth1/1/3)# description ToR2-Hosts
    ToR2(conf-if-eth1/1/3)# mtu 9216
    ToR2(conf-if-eth1/1/3)# switchport mode trunk
    ToR2(conf-if-eth1/1/3)# switchport trunk allowed vlan 2001
    ToR2(conf-if-eth1/1/3)# exit
  3. Configure BGP neighbors, and advertise the host subnet.
    ToR2(config)# router bgp 65302
    ToR2(config-router-bgp-65302)# router-id 10.0.2.2
    ToR2(config-router-bgp-65302)# address-family ipv4 unicast
    ToR2(configure-router-bgpv4-af)# network 172.16.2.0/24
    ToR2(configure-router-bgpv4-af)# exit
    ToR2(config-router-bgp-65302)# neighbor 10.5.1.0
    ToR2(config-router-neighbor)# remote-as 65202
    ToR2(config-router-neighbor)# no shutdown
    ToR2(config-router-neighbor)# exit
    ToR2(config-router-bgp-65302)# neighbor 10.6.1.0
    ToR2(config-router-neighbor)# remote-as 65202
    ToR2(config-router-neighbor)# no shutdown
    ToR2(config-router-neighbor)# exit

Rate this content

Accurate
Useful
Easy to understand
Was this article helpful?
0/3000 characters
  Please provide ratings (1-5 stars).
  Please provide ratings (1-5 stars).
  Please provide ratings (1-5 stars).
  Please select whether the article was helpful or not.
  Comments cannot contain these special characters: <>()\