Skip to main content
  • Place orders quickly and easily
  • View orders and track your shipping status
  • Create and access a list of your products
  • Manage your Dell EMC sites, products, and product-level contacts using Company Administration.

Dell EMC SmartFabric OS10 User Guide Release 10.5.0

PIM-SM sample configuration

This section describes how to enable PIM-SM in the FHR, RP, and LHR nodes using the topology show in the following illustration.

To enable PIM-SM, perform the following configurations on each of the nodes (FHR, RP, and LHR):

  • Enable multicast routing on all the nodes using the ip multicast-routing command

  • Enable PIM-SM on all the required Layer 3 interfaces of the nodes using the ip pim sparse-mode command

  • Configure an RP address on every multicast enable node using the ip pim rp-address command

  • Configure an IP address for each interface of the nodes in the PIM-SM topology

  • Enable a routing protocol (OSPF) for route updates

PIM-SM sample topology

Sample configuration in FHR node:

FHR# configure terminal
FHR(config)#
FHR(config)# ip multicast-routing
FHR(config)# interface ethernet 1/1/31
FHR(conf-if-eth1/1/31)# no switchport
FHR(conf-if-eth1/1/31)# ip address 3.3.3.2/24
FHR(conf-if-eth1/1/31)# ip pim sparse-mode
FHR(conf-if-eth1/1/31)# ip ospf 1 area 0
FHR(conf-if-eth1/1/31)# exit
FHR(config)#
FHR(config)# interface ethernet 1/1/17
FHR(conf-if-eth1/1/17)#
FHR(conf-if-eth1/1/17)# no switchport
FHR(conf-if-eth1/1/17)# ip address 2.2.2.2/24
FHR(conf-if-eth1/1/17)# ip pim sparse-mode
FHR(conf-if-eth1/1/17)# ip ospf 1 area 0
FHR(conf-if-eth1/1/17)# exit
FHR(config)# router ospf 1
FHR(config-router-ospf-1)# exit
FHR(config)# ip pim rp-address 192.168.1.25 group-address 224.0.0.0/4
FHR(config)#
FHR# configure terminal
FHR(config)# interface ethernet 1/1/48
FHR(conf-if-eth1/1/48)# no switchport
FHR(conf-if-eth1/1/48)# ip address 22.1.1.2/24
FHR(conf-if-eth1/1/48)# ip pim sparse-mode
FHR(conf-if-eth1/1/48)# ip ospf 1 area 0
FHR(conf-if-eth1/1/48)#

The show ip pim interface command displays the PIM-enabled interfaces in FHR.

FHR# show ip pim interface
Address       Interface           Ver/Mode      Nbr Count    Query Intvl      DR Prio      DR
---------------------------------------------------------------------------------------------------
2.2.2.2       ethernet1/1/17      v2/S          1            30               1            2.2.2.2
3.3.3.2       ethernet1/1/31      v2/S          1            30               1            3.3.3.2
22.1.1.2      ethernet1/1/48      v2/S          0            30               1            22.1.1.2
FHR#

The show ip pim neighbor command displays the PIM neighbor of FHR and the interface to reach the neighbor.

FHR# show ip pim neighbor
Neighbor Address         Interface            Uptime/Expires         Ver        DR Priority/Mode
---------------------------------------------------------------------------------------------
2.2.2.1                  ethernet1/1/17      00:04:31/00:01:43        v2           1   / S
3.3.3.1                  ethernet1/1/31      00:05:45/00:01:31        v2           1   / S
FHR#

The show ip pim rp mapping command displays the multicast groups to RP mapping and information about how RP is learned.

FHR# show ip pim rp mapping
Group(s) : 224.0.0.0/4,  Static
RP : 192.168.1.25, v2

Sample configuration in RP node:

RP# configure terminal
RP(config)# ip multicast-routing
RP(config)# interface ethernet 1/1/31
RP(conf-if-eth1/1/31)# no switchport
RP(conf-if-eth1/1/31)# ip address 3.3.3.1/24
RP(conf-if-eth1/1/31)# ip pim sparse-mode
RP(conf-if-eth1/1/31)# ip ospf 1 area 0
RP(conf-if-eth1/1/31)# exit
RP(config)#
RP(config)# interface ethernet 1/1/43
RP(conf-if-eth1/1/43)# no switchport
RP(conf-if-eth1/1/43)# ip address 1.1.1.2/24
RP(conf-if-eth1/1/43)# ip pim sparse-mode
RP(conf-if-eth1/1/43)# ip ospf 1 area 0
RP(conf-if-eth1/1/43)# exit
RP(config)#
RP(config)# interface loopback 0
RP(conf-if-lo-0)# ip address 192.168.1.25/32
RP(conf-if-lo-0)# ip ospf 1 area 0
RP(conf-if-lo-0)# exit
RP(config)# ip pim rp-address 192.168.1.25 group-address 224.0.0.0/4
RP(config)# end
RP#
RP# configure terminal
RP(config)# router ospf 1
RP(config-router-ospf-1)# end

The show ip pim interface command displays the PIM-enabled interfaces in RP.

RP# show ip pim interface
Address      Interface            Ver/Mode       Nbr Count    Query Intvl      DR Prio      DR
---------------------------------------------------------------------------------------------------
3.3.3.1      ethernet1/1/31       v2/S           1            30               1            3.3.3.2
1.1.1.2      ethernet1/1/43       v2/S           1            30               1            1.1.1.2
RP#

The show ip pim neighbor command displays the PIM neighbor of RP and the interface to reach the neighbor.

RP# show ip pim neighbor
Neighbor Address         Interface            Uptime/Expires         Ver        DR Priority/Mode
-----------------------------------------------------------------------------------------------
3.3.3.2                  ethernet1/1/31      00:02:57/00:01:17        v2           1   / DR S
1.1.1.1                  ethernet1/1/43      00:06:35/00:01:39        v2           1   / S
RP#

Sample configuration in LHR node:

LHR# configure terminal
LHR(config)# ip multicast-routing
LHR(config)# interface ethernet 1/1/17
LHR(conf-if-eth1/1/17)#
LHR(conf-if-eth1/1/17)# no switchport
LHR(conf-if-eth1/1/17)# ip address 1.1.1.1/24
LHR(conf-if-eth1/1/17)# ip pim sparse-mode
LHR(conf-if-eth1/1/17)# ip ospf 1 area 0
LHR(conf-if-eth1/1/17)# exit
LHR(config)#
LHR(config)# interface ethernet 1/1/29
LHR(conf-if-eth1/1/29)# no switchport
LHR(conf-if-eth1/1/29)# ip address 2.2.2.1/24
LHR(conf-if-eth1/1/29)# ip pim sparse-mode
LHR(conf-if-eth1/1/29)# ip ospf 1 area 0
LHR(conf-if-eth1/1/29)# exit
LHR(config)#
LHR(config)# ip pim rp-address 192.168.1.25 group-address 224.0.0.0/4
LHR(config)# end
LHR(config)# interface vlan 2001
LHR(conf-if-vl-2001)# no shutdown
LHR(conf-if-vl-2001)# ip address 15.1.1.1/24
LHR(conf-if-vl-2001)# ip pim sparse-mode
LHR(conf-if-vl-2001)# ip ospf 1 area 0
LHR(conf-if-vl-2001)# exit
LHR(config)#
LHR(config)# interface ethernet 1/1/38
LHR(conf-if-eth1/1/38)# switchport mode trunk
LHR(conf-if-eth1/1/38)# no switchport access vlan
LHR(conf-if-eth1/1/38)# switchport trunk allowed vlan 2001
LHR(conf-if-eth1/1/38)# exit
LHR# configure terminal
LHR(config)# router ospf 1
LHR(config-router-ospf-1)# end

The show ip pim interface command displays the PIM-enabled interfaces in LHR.

LHR# show ip pim interface
Address  Interface         Ver/Mode  Nbr Count Query Intvl  DR Prio  DR
----------------------------------------------------------------------------
2.2.2.1  ethernet1/1/1      v2/S      1         30           1      2.2.2.2
1.1.1.1  ethernet1/1/26:1   v2/S      1         30           1      1.1.1.2
15.1.1.1 vlan2001           v2/S      0         30           1      15.1.1.1

The show ip pim neighbor command displays the PIM neighbor of LHR and the interface to reach the neighbor.

LHR# show ip pim neighbor
Neighbor Address Interface       Uptime/Expires     Ver  DR Priority/Mode
---------------------------------------------------------------------
2.2.2.2          ethernet1/1/17  00:02:58/00:01:24  v2   1   / DR S
1.1.1.2          ethernet1/1/29  00:07:49/00:01:31  v2   1   / DR S
LHR# show ip pim rp mapping
Group(s) : 224.0.0.0/4,  Static
RP : 192.168.1.25, v2

The following show command output examples display the PIM states across all nodes after IGMP join and multicast traffic is received.

PIM states in FHR node

The show ip pim tib command output displays the PIM tree information base (TIB).

FHR# show ip pim tib

PIM Multicast Routing Table
Flags: S - Sparse, C - Connected, L - Local, P - Pruned,
       R - RP-bit set, F - Register Flag, T - SPT-bit set, J - Join SPT,
       K - Ack-Pending state
Timers: Uptime/Expires
Interface state: Interface, next-Hop, State/Mode

(22.1.1.10, 224.1.1.1), uptime 00:02:20, expires 00:01:09, flags: T
  Incoming interface: ethernet1/1/48, RPF neighbor 0.0.0.0
  Outgoing interface list:
    ethernet1/1/17  Forward/Sparse  00:00:19/00:03:10

The show ip pim mcache command output displays multicast route entries.

FHR# show ip pim mcache
PIM Multicast Routing Cache Table

(22.1.1.10,224.1.1.1)
  Incoming interface : ethernet1/1/48
  Outgoing interface list :
   ethernet1/1/17

PIM states in RP node

RP# show ip pim tib

PIM Multicast Routing Table
Flags: S - Sparse, C - Connected, L - Local, P - Pruned,
       R - RP-bit set, F - Register Flag, T - SPT-bit set, J - Join SPT,
       K - Ack-Pending state
Timers: Uptime/Expires
Interface state: Interface, next-Hop, State/Mode

(*, 224.1.1.1), uptime 00:00:57, expires 00:00:00, RP 192.168.1.25, flags: S
  Incoming interface:  Null, RPF neighbor 0.0.0.0
  Outgoing interface list:

(22.1.1.10, 224.1.1.1), uptime 00:02:58, expires 00:03:06, flags: P
  Incoming interface: ethernet1/1/31, RPF neighbor 3.3.3.2
  Outgoing interface list:

IGMP and PIM states in LHR node

The show ip igmp groups command output displays the IGMP database.

LHR# show ip igmp groups
Total Number of Groups: 1
IGMP Connected Group Membership
Group Address                 Interface           Mode                Uptime              Expires             Last Reporter
224.1.1.1                     vlan2001            IGMPv2-Compat       00:00:01            00:01:59            15.1.1.10
LHR#
LHR# show ip pim tib

PIM Multicast Routing Table
Flags: S - Sparse, C - Connected, L - Local, P - Pruned,
       R - RP-bit set, F - Register Flag, T - SPT-bit set, J - Join SPT,
       K - Ack-Pending state
Timers: Uptime/Expires
Interface state: Interface, next-Hop, State/Mode

(*, 224.1.1.1), uptime 00:00:05, expires 00:00:54, RP 192.168.1.25, flags: SCJ
  Incoming interface: ethernet1/1/29, RPF neighbor 1.1.1.2
  Outgoing interface list:
    vlan2001  Forward/Sparse  00:00:05/Never

(22.1.1.10, 224.1.1.1), uptime 00:00:05, expires 00:03:24, flags: T
  Incoming interface: ethernet1/1/17, RPF neighbor 2.2.2.2
  Outgoing interface list:
    vlan2001  Forward/Sparse  00:00:05/Never
LHR# show ip pim mcache
PIM Multicast Routing Cache Table

(*, 224.1.1.1)
  Incoming interface : ethernet1/1/29
  Outgoing interface list :
   vlan2001

(22.1.1.10,224.1.1.1)
  Incoming interface : ethernet1/1/17
  Outgoing interface list :
   vlan2001

Rate this content

Accurate
Useful
Easy to understand
Was this article helpful?
0/3000 characters
  Please provide ratings (1-5 stars).
  Please provide ratings (1-5 stars).
  Please provide ratings (1-5 stars).
  Please select whether the article was helpful or not.
  Comments cannot contain these special characters: <>()\