NVP vProxy: backup or clone fails on "retention lock" enabled DD devices after upgrading to NetWorker 19.6
Summary: VMs protected by the NetWorker vProxy appliance fail to backup and or clone after the NetWorker server was upgraded to 19.6 from a previous release. The Data Domain devices that are used are configured with the "retention lock" feature. ...
This article applies to
This article does not apply to
This article is not tied to any specific product.
Not all product versions are identified in this article.
Symptoms
- NetWorker server was upgraded to 19.6.0 from a previous release.
- The Data Domain Devices are configured with "retention lock" (Governance or Compliance).
- VM backup and or clone operations are failing with the following error.
Error:
nsrmmd#2 SYSTEM critical Unable to remove SSID file '/linux1/SNDDCLRL/85/22/df901338-00000006-f8fc555f-61fc555f-00095000-9b240656' on device 'rd=dc.amer.lan:ddve1.amer.lan_SNDDCLRL': Unable to stat save set file '/linux1/SNDDCLRL/85/22/df901338-00000006-f8fc555f-61fc555f-00095000-9b240656': Retrieving statistics for '/linux1/SNDDCLRL/85/22/df901338-00000006-f8fc555f-61fc555f-00095000-9b240656' failed [5004] ([ 3172] [4820] Thu Feb 03 17:38:10 2022 ddp_stat() failed, Path //linux1/SNDDCLRL/85/22/df901338-00000006-f8fc555f-61fc555f-00095000-9b240656, Err: 5004-nfs lookup failed (nfs: No such file or directory) ).
Cause
The ddboost user is not granted for the right of RL enabled mtree.
Resolution
The issue has been fixed in 19.6.1, which is tentatively targeted for release April 2022.
Workaround:
Create a new device labeled to a new pool; when creating the device leave the "DD Retention Lock" checkbox empty. Configure the VM backup and clone operations to clone to devices without retention lock enabled. Optionally, instead of configuring new devices the NetWorker server can be downgraded to NetWorker 19.5 until 19.6.1 is available.
Additional Information
For more information on Data Domain Retention Lock refer to the 'Dell EMC NetWorker Data Domain Boost Integration Guide' available through https://www.dell.com/support/home/product-support/product/networker/docs
NetWorker package downloads are available through: https://www.dell.com/support/home/product-support/product/networker/drivers
NetWorker package downloads are available through: https://www.dell.com/support/home/product-support/product/networker/drivers
Affected Products
NetWorker FamilyArticle Properties
Article Number: 000196085
Article Type: Solution
Last Modified: 02 Dec 2022
Version: 6
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.