Data Protection Advisor (DPA): PPDM request fails with function caught ProcessingException
Summary: Data collection request for PPDM fails with message function caught ProcessingException.
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Symptoms
The Job Monitor data collection requests for PPDM are failing with the following status:
Function jobmonitor caught ProcessingException
The Debug low dpaagent.log captures the API request which caused the exception:
DBG1 . 20210305:014537 org.apache.logging.log4j.spi.AbstractLogger - get(): GET [/api/v2/assets?pageSize=5000&page=1]
ERR . 20210305:014637 org.apache.logging.log4j.spi.AbstractLogger - execute(): Function jobmonitor caught ProcessingException
The log shows that there is exactly 60sec between the API request and the ProcessingException message.
Function jobmonitor caught ProcessingException
The Debug low dpaagent.log captures the API request which caused the exception:
DBG1 . 20210305:014537 org.apache.logging.log4j.spi.AbstractLogger - get(): GET [/api/v2/assets?pageSize=5000&page=1]
ERR . 20210305:014637 org.apache.logging.log4j.spi.AbstractLogger - execute(): Function jobmonitor caught ProcessingException
The log shows that there is exactly 60sec between the API request and the ProcessingException message.
Cause
Within the PPDM Job Monitor requests there is an option called Request Timeout (Seconds).
Default value for this timeout is 60sec.
In some cases the PPDM server may not respond to the request within that 60sec timeout resulting in the ProcessingException message with DPA.
Default value for this timeout is 60sec.
In some cases the PPDM server may not respond to the request within that 60sec timeout resulting in the ProcessingException message with DPA.
Resolution
Use a rest api client to check how long it take for the PPDM Server to respond to the request.
Increase the Request Timeout (Seconds) option on the PPDM request until the request is successful.
Please contact Dell Technical Support for further information.
Increase the Request Timeout (Seconds) option on the PPDM request until the request is successful.
Please contact Dell Technical Support for further information.
Products
Data Protection AdvisorArticle Properties
Article Number: 000184327
Article Type: Solution
Last Modified: 10 Jan 2022
Version: 3
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