Avamar SQL 클러스터 백업이 실패하고 다음 오류가 발생합니다. 원격 클라이언트에 연결할 수 없습니다.
Summary: --clusternode 플래그를 사용하는 경우에도 SQL 플러그인이 보조 복제본에 잘못된 IP 주소를 사용함
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Symptoms
듀얼 홈 AlwaysON 클러스터의 Avamar SQL 백업이 실패합니다.
기본 avsql 플러그인 로그에서 다음을 수행합니다.
2017/01/26-11:46:01.41899 [avsql_assist] avsql_iac_manager::forward_ctl_message() received response dequeued_ret on queue remote 2017-01-26 12:46:01 avsql Error <0000>: Unable to connect to the remote client '10.x.x.22', error code: 2. Please ensure that the remote backup agent is running. 2017/01/26-11:46:01.41899 [avsql_assist] <=== avsql_iac_manager::forward_ctl_message 2017-01-26 12:46:01 avsql Error <12758>: [<Cluster-Client-name>] is unable to forward CTL sub-workorder to [<SQL-SRV-name\instance-name>]. 2017/01/26-11:46:01.41899 [avsql_assist] ===> avsql_iac_manager::update_client_status 2017-01-26 12:46:01 avsql Info <17370>: Remote client: <SQL-SRV-name\instance-name> (10.x.x.22), Status: FAILED From remote client avagent log we don't see any sub-workorder as the IP in question (10.x.x.22) cannot be contacted from backup IP of AlwaysON listener (10.x.x.81):
initiator_agent_ip="10.x.x.81" remote_agent_ip="10.x.x.22"
Cause
듀얼 홈 AlwaysON SQL 클러스터 환경의 경우 SQL 노드의 FQDN(Fully Qualified Domain Name)이 운영 네트워크의 IP 주소로 확인됩니다. 이 네트워크는 백업 네트워크에 액세스할 수 없습니다.
이 문제는 다중 NIC 환경 또는 서로 다른 vLAN이 관련된 경우에 발생할 수 있습니다.
Resolution
영구 해결 방법:
Avamar Server를 로 업그레이드합니다.
- 19.7.100-82 이상
- 이 수정 사항은 Avamar 19.7 이상의 소프트웨어 릴리스에 통합되었습니다.
- AlwaysON 공유 VAR의 avsql.cmd 파일에 있는 새 플래그:
-
--clusternode=<SQL_node_name>(<IP_ADDRESS>)
-
- AlwaysON 공유 VAR의 avsql.cmd 파일에 있는 새 플래그:
Affected Products
AvamarProducts
Avamar, Avamar Client, Avamar Plug-in for SQLArticle Properties
Article Number: 000070983
Article Type: Solution
Last Modified: 11 Jun 2024
Version: 6
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