NVP vProxy: Backups Fail with "Unable to select a device from the client's 'backup target disks' attribute"
Summary: VM backups performed through the NVP vProxy appliance fail with indicating that the workflow cannot identify a target backup device for the vCenter server.
Symptoms
The NetWorker VMware Protection integration is configured with the vProxy Appliance. The virtual machine (VM) backups fail with:
nsrvproxy_save NSR error Unable to process VM 'VM_NAME': Unable to select a device from the client's 'backup target disks' attribute. All backup target disks for client 'vCenter_Server_Name' are either not available or not mounted
Cause
The symptom can have several causes, and these are the most common causes:
- The target backup device DD Boost user account password has been locked on the Data Domain.
- The target backup DDboost devices are not enabled or mounted.
Resolution
Locked ddboost user account:
Reset the Data target backup device DD Boost user account password.
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Open an ssh session to the Data Domain and log in with a Data Domain admin account.
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Validate if the Data Domain DD Boost user account is locked:
user show list
In the following example, the account ddvebst is the DD Boost account the NetWorker devices are using
sysadmin@ddve# user show list User list from node "localhost". Name Uid Role Last Login From Last Login Time Status Disable Date -------- --- ----- ----------------- ------------------------ ------- ------------ sysadmin 100 admin networker.###.com Thu Jun 28 14:30:59 2018 enabled never ddvebst 500 admin ebr.###.com Thu Jun 28 14:28:16 2018 locked never -------- --- ----- ----------------- ------------------------ ------- ------------ 2 users found.
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Unlock the DD Boost user account:
user enable [User_Account]
sysadmin@ddve# user enable ddvebst User "ddvebst" has been enabled.
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Verify in the NetWorker Management Console (NMC) "Devices > Data Domains > Affected_Data_Domain" that the devices are now mounted. If not, manually mount them so that the backups can be run.
The device is not enabled or mounted:
If the ddboost account does not show as "Locked", check the following device status and KB articles for other causes of the issue:
DDboost devices the backup is trying to write to are not enabled or mounted:
Check the NMC "Devices > Data Domains > Affected_Data_Domain > ddboost_device" and ensure they are enabled and mounted.
Try unmounting and re-mounting the device to ensure NetWorker can access the device on the Data Domain. If you encounter an error trying to unmount or mount the devices, verify that the ddboost password is up to date in NetWorker.
NetWorker Family: DD Boost device is Marked as suspect