DD System Manager UI Tomcat: Resolving Error: MSG-PMON-00012: Cannot restart
Summary: This KB describes in further detail the procmon alert Error: MSG-PMON-00012: Cannot restart /ddr/bin/sm_em. Setting state to FAILED which can generate on DDOS 6.0 AND 6.1 releases.
Symptoms
Issue
System Manager UI access issue or the following alert appears:ddr_procmon: ALERT: MSG-PMON-00012: Cannot restart /ddr/bin/sm_em. Setting state to FAILED.
The alert can be seen on the console itself and in messages.engineering.
There will be no alerts seen in #alerts show current
Note: This alert has also been seen with DDVE
The procmon alert is commonly seen;
- After DDOS upgrade
- After a system reboot
- After restarting the http web services, i.e, adminaccess enable http
- After running other adminaccess commands
Cause
Procmon's job is to restart a process, if it has failed/exited. And if a process repeatedly keeps failing, procmon throws an alert about it.
Earlier Releases:
Procmon has been configured to monitor the sm_em process. When sm_em dies, procmon restarts it.
sm_em internally starts Apache inline, sm_em keeps waiting at this line, until Apache is running. If Apache quits for any reason, sm_em moves forward and exit. Procmon is monitoring sm_em, it restarts sm_em, and as a result Apache is started again by sm_em.
What changed in the last release:
sm_em is starting Apache in the background. Therefore, it does not stop execution of sm_em. sm_em moves ahead and quits.
Procmon is still monitoring sm_em. It restarts sm_em, and throws an alert when sm_em keeps on quitting every time.
Resolution
Workaround
Restarting the system's web service, by disabling then re-enabling them using the below commands on DD CLI or Putty can bring up the UI if it is inaccessible but will not suppress the alerts:ddr## adminaccess disable httpddr## adminaccess disable httpsddr## adminaccess enable httpddr## adminaccess enable https
Above commands should restart tomcat services. Open DD System Manager UI to review the status.
If the issue persists, contact Dell support and refer this article.
Resolution
Upgrade to the latest DDOS release for fixes