Dell Unity: SAS expander faulted after SP replacement
Summary: This KB will explain the SAS Expander fault error reported by Unity after replacing an SP. (User Correctable)
Symptoms
One of the SPs was replaced.
After replacing an SP, Unity Array reports the SAS expander in one of the SPs as faulted and goes to degraded state.
The following error message can be seen (from Unisphere):
The SAS expander in Storage Processor SP X has faulted (Part Number 303-297-005C-05, Serial Number XXXXXXXXXXXXXX). SAS expander in the Storage Processor (SP) has faulted. Check the system logs and try rebooting the SP. If the problem persists, you may need to replace the SP.
Cause
When an SP with a different 'SP Expander' firmware revision is inserted, a mismatch for the 'SP Expander' firmware revision is detected.
Due to this Unity reports the SAS expander in one of the Storage Processors has been faulted.
Resolution
After SP replacement, the 'SP Expander' firmware revision is automatically upgraded within a few hours.
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Error should clear after new 'SP Expander' firmware is upgraded successfully.
You may have to restart management Services to clear the error (after few hours of SP replacement).Steps for restarting the Management Services are here: How to restart the Management Services
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If the error persists, contact the Dell Technical Support team.
Additional Information
- In one case, both 'SP Expanders' were running on firmware revision of 2.20.0
- SP A was replaced at 02:25:56 on a particular day, and it was running on 'SP Expander' firmware revision of 1.4.0
- Then Unity reported "The SAS expander in Storage Processor SP A has faulted" at 02:28:11
- 'SP Expander' firmware upgrade on SP A succeeded at 04:25:30 and after restarting management services the error got cleared.