DPA agent registration fails to send – Error code 12175
Summary: DPA agent registration fails to send – Error code 12175. Issue started happening after Windows Security patch upgrade applied. Workaround is disable SSL at the dpaagent_config.xml file of the agent in order to re-establish data collections ...
This article applies to
This article does not apply to
This article is not tied to any specific product.
Not all product versions are identified in this article.
Symptoms
The DPA Agent fails to register with the DPA Server.
The following error message is logged in the DPA Agent log:
ERR 6552.8236 20160728:114045 com.http - httpSendRequest(): Failed to send request to https://127.0.0.1:9002/dpa-api/agent/registration: 12175
ERR 6552.8236 20160728:114045 agent.config - initAgentConfig(): Failed to register agent with the server. Waiting to retry...
It is the agent resident on the App server.
Issue started happening after Windows Security patch upgrade applied .
It seems the Windows security patch somehow impacted the SSL library at the OS level on the App server causing the App agent was no longer able to register with the App server and the collected data couldn t be sent to the server.
When we tried the agent registration URL using secure connection https://127.0.0.1:9002/dpa-api/agent/registration it showed Internet Explorer cannot display the webpage but when we tried the non-secure connection http://127.0.0.1:9004/dpa-api/agent/registration we get prompted for credentials successfully.
The agent is not able to connect to the App server on a secure connection as it was before applying the Windows security patch and now connects to the App server only on non-secure connection.
Cause
The cause of this issue is not known at this time.
Resolution
There is no resolution to this issue at this time.
Workaround:
Disable SSL at the dpaagent_config.xml file of the agent in order to re-establish data collections.
1. Set following lines on the dpaagent_config.xml file under <Install_dir>\agent\etc folder on the agent host:
<SERVERPORT>9004</SERVERPORT>
<SERVERSSL>false</SERVERSSL>
2. Restart agent services for the changes to take place.
Please contact EMC Technical Support for further details or information.
Workaround:
Disable SSL at the dpaagent_config.xml file of the agent in order to re-establish data collections.
1. Set following lines on the dpaagent_config.xml file under <Install_dir>\agent\etc folder on the agent host:
<SERVERPORT>9004</SERVERPORT>
<SERVERSSL>false</SERVERSSL>
2. Restart agent services for the changes to take place.
Please contact EMC Technical Support for further details or information.
Affected Products
App Direct File System AgentArticle Properties
Article Number: 000065120
Article Type: Solution
Last Modified: 06 May 2025
Version: 3
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.