Dell G5 5590 Backlit Keyboard Not Affected by Keyboard Hotkeys

Summary: The following article provides information about the backlit keyboard on the Dell G5 5590 laptop. The issue is that the computer is not responding to the keyboard hotkeys and recommended troubleshooting if you are experiencing a keyboard issue. ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms


Table of Contents:

  1. Keyboard backlight hotkeys do not work?
  2. Important information about the keyboard on the G5 5590 laptop
  3. Recommended troubleshooting

Keyboard backlight hotkeys do not work?

 

SLN319180_en_US__15590_G5_Prod_Shot_BK

(Figure.1 Dell G5 5590 Front View)

Some owners have reported that the keyboard backlight on their Dell G5 5590 laptop does not respond. This happens when using the Fn + F10 key keyboard shortcut. They also report that it takes time to activate the keyboard function keys (hotkeys) after the computer starts up.

This article takes you through important information that you should know about the backlit keyboards available on the G5 5590 laptop. It includes our recommended troubleshooting to help you identify a keyboard issue.


Back to Top


Cause

Important information about the keyboard on the G5 5590 laptop

 

There are three keyboard options available for the G5 5590 computer. Knowing which one is in your computer can tell you what you can expect from it:

(Table.1 Keyboard type and function)

Keyboard Type Backlight Function
Standard non-backlit keyboard There is no backlight function
Standard backlit keyboard - Bluelight (Optional) The Fn + F10 key combination works in the BIOS and the Operating System
Four-zone RGB (Red/Green/Blue) backlit keyboard (Optional) Hotkey does not work outside of the Operating System and can only be adjusted in the AWCC utility

 

Expected behavior for a keyboard backlight on the Dell G5 5590 laptop:

  • If the backlight is ON and we restart or shut down the computer, when it returns the backlight is still ON
  • If the backlight is OFF and we restart or shut down the computer, when it returns the backlight is still OFF
  • The last status of the backlight is kept
  • Once in the Operating System, if you were to try to change the backlight (turn-on/turn-off) status just after the computer completes startup, it does not work. However, if you wait approximately 1 minute after startup to change the backlight status by using the Fn + F10 keys, then it works as designed. (This is because of the Multiple DELL APP startup type defaults as Automatic (Delay Start).). The Alienware Command Center (AWCC) utility is one of these Dell apps

 

Note: Pressing the Fn + ESC keys together deactivates all of the function keys (hotkeys), so no commands using them can be activated, this includes the backlight. Press the Fn + ESC keys together again to reactivate the function/hotkeys.

 

Note: If you need to test the RGB backlight outside of the Operating System, you can use the Liquid Crystal Display (LCDS) Built-In Self-Test (BIST) test. The backlight colors change in the first sequence of the LCD-BIST after the screen goes off and a new sequence of the LCD-BIST starts. The backlight remains in the default state that was set in the computer.


Back to Top


Resolution

Recommended troubleshooting

 

If your keyboard is behaving differently from what is described above? If you are experiencing a different keyboard fault? You can choose the appropriate troubleshooting article from the following link pages that are most relevant for this computer:


Back to Top


Affected Products

Dell G5 15 5590
Article Properties
Article Number: 000139263
Article Type: Solution
Last Modified: 31 Jul 2025
Version:  12
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.