AppSync: Replacing Self-Signed Certificate with CA Certificate fails with error
Summary: Older versions of OpenSSL can cause issues when importing certificates for use with AppSync.
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This article is not tied to any specific product.
Not all product versions are identified in this article.
Symptoms
When trying to replace a self signed certificate with a CA certificate for use with AppSync, the process fails with the following error.
java.lang.Exception: Certificate not imported, alias <appsync> already exists
This error may be seen after the following commands are run as part of the process.
C:\EMC\AppSync\jboss\_jre\bin\keytool -importcert -file C:\OpenSSL\cert.pem -keystore C:\EMC\AppSync\jboss\_jre\lib\security\cacerts -storepass changeit -alias appsync noprompt
Cause
The version of OpenSSL installed in the environment was 1.0.2j 64 bit.
Issues have been observed with importing certificates when the version of openSSL is from the 1.0.2 branch and older.
Issues have been observed with importing certificates when the version of openSSL is from the 1.0.2 branch and older.
Resolution
Upgrading to OpenSSL version 1.1.0h resolved this issue.
If this issue is encountered in future, it is recommended to upgrade to the latest available version of OpenSSL.
The latest versions of OpenSSL are available to download at https://www.openssl.org/source/
If this issue is encountered in future, it is recommended to upgrade to the latest available version of OpenSSL.
The latest versions of OpenSSL are available to download at https://www.openssl.org/source/
Additional Information
This content is translated in different languages:
For more information on replacing a self-signed certificate with a CA certificate, please see the AppSync 3.9 Security and Configuration Guide, page 26, available from the AppSync product support page.
https://support.emc.com/products/25364_AppSync
| https://downloads.dell.com/TranslatedPDF/PT-BR_KB533599.pdf |
| https://downloads.dell.com/TranslatedPDF/ZH-CN_KB533599.pdf |
| https://downloads.dell.com/TranslatedPDF/AR-EG_KB533599.pdf |
| https://downloads.dell.com/TranslatedPDF/DE_KB533599.pdf |
| https://downloads.dell.com/TranslatedPDF/ES_KB533599.pdf |
| https://downloads.dell.com/TranslatedPDF/FR_KB533599.pdf |
| https://downloads.dell.com/TranslatedPDF/KO_KB533599.pdf |
| https://downloads.dell.com/TranslatedPDF/JA_KB533599.pdf |
| https://downloads.dell.com/TranslatedPDF/IT_KB533599.pdf |
| https://downloads.dell.com/TranslatedPDF/NL_KB533599.pdf |
| https://downloads.dell.com/TranslatedPDF/PT_KB533599.pdf |
| https://downloads.dell.com/TranslatedPDF/RU_KB533599.pdf |
| https://downloads.dell.com/TranslatedPDF/SV_KB533599.pdf |
For more information on replacing a self-signed certificate with a CA certificate, please see the AppSync 3.9 Security and Configuration Guide, page 26, available from the AppSync product support page.
https://support.emc.com/products/25364_AppSync
Affected Products
AppSyncProducts
AppSyncArticle Properties
Article Number: 000168555
Article Type: Solution
Last Modified: 18 Sep 2025
Version: 4
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