Dell Unity: After Upgrading Unity OE to Version 5.1 or Later, the Veeam Backups Stop Working

Summary: The Veeam backups do not complete after upgrading Unity OE to version 5.1 or later. It is unclear whether other Unity OE versions have Veeam backups not working. (Dell Correctable)

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Backups stop with the following error message:
ErrorCode: '16777239', Message: 'There is a syntax error in the command.  Please recheck the command syntax. (Error Code: 0x1000017)'.

Cause

Veeam relied on the output of a UEMCLI command:
uemcli /sys/general show -output csv -filter "System name, Model, Platform type, Product serial number"
Before Unity OE version 5.1, the output contained a field that is called "Platform type" and it responded like this on Unity:
Platform type = EMC Storage System
This field was deprecated in OE 5.0 code, and was fully removed in OE 5.1 code. The Veeam UEMCLI call returns a syntax error after Unity is upgraded to 5.1.


Update for Unity 5.4

The Command line uemcli /sys/general show does not include the field Platform type. The output below shows the Veeam filter query that failed.
20:23:04 service@APM00192427000 spa:~/user# uemcli /sys/general show -output csv -filter "System name, Model, Platform type, Product serial number"
Storage system address: 127.0.0.1
Storage system port: 443
HTTPS connection

Operation failed. Error code: 0x1000017
Command line parsing failed near "Platform type" token.
There is a syntax error in the command. Please recheck the command syntax. (Error Code:0x1000017)

20:23:14 service@APM00192427000 spa:~/user# uemcli /sys/general show -output csv -filter "System name, Model, Product serial number"
Storage system address: 127.0.0.1
Storage system port: 443
HTTPS connection

"System name","Model","Product serial number"
"APM00192427000","Unity 480","APM00192427000"
20:23:26 service@APM00192427000 spa:~/user# 

Resolution

Solution

Upgrade your Veeam installation to Veeam B&R version 11a. For additional assistance, contact Veeam Technical Support This hyperlink is taking you to a website outside of Dell Technologies..

If Unity is still running OE version 5.1.0.0.5.394 and Veeam cannot be upgraded to Veeam B&R version 11a, contact Dell Technical Support, or your Authorized Service Provider and quote this Dell Knowledge Base article ID.

Affected Products

Dell EMC Unity
Article Properties
Article Number: 000189458
Article Type: Solution
Last Modified: 25 Jul 2024
Version:  15
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