VxRail: ESXi Host Failed to Enter Name Namespaces Maintenance Mode

Summary: Entering or exiting maintenance mode through the vSphere Web Client is not possible. This occurs after an upgrade or patch of the internal or external vCenter, to a version in the 7.0 family. ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Entering or exiting maintenance mode through the vSphere Web Client is not possible. 
This occurs after an upgrade or patch of the internal or external vCenter, to a version in the 7.0 family.

When connecting to vCenter through SSH or telnet and checking services, it returns:

service-control --status --all
STOPPED: wcp

vCenter vpxd.log:

WCP enterMaintenanceMode vAPI returns error: Error:
--> com.vmware.vapi.std.errors.unauthenticated
--> Messages:
--> vapi.security.authentication.invalid<Unable to authenticate user>

Failed to delete vAPI session. Error:
--> Error:
--> com.vmware.vapi.std.errors.unauthenticated
--> Messages:
--> vapi.security.authentication.invalid<Unable to authenticate user>

Cause

In the version 7.0 family of vCenter, the WCP-Service handles maintenance operations. The configuration file for that service may be missing port information after an upgrade or patch of the vCenter.

Resolution

To resolve this issue: 

  1. Create a Snapshot of the vCenter and then ssh to vCenter as root.
  2. Create a backup of /etc/vmware/wcp/wcpsvc.yaml by command:
cp /etc/vmware/wcp/wcpsvc.yaml /etc/vmware/wcp/wcpsvc.yaml.bak
  1. Change this line rhttpproxy_port: {rhttpproxy.ext.port2} in the above YAML file to rhttpproxy_port: 443   
  2. Start the WCP-service with the command:
service-control --start wcp

If the above actions do not solve the issue, check Broadcom Article This hyperlink is taking you to a website outside of Dell Technologies..

Affected Products

VxRail, VxRail Appliance Series, VxRail Software
Article Properties
Article Number: 000192615
Article Type: Solution
Last Modified: 22 May 2025
Version:  7
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.