Dell ThinOS 9 Performs a Network Diagnostic After a Failed Connection Attempt
Summary: This article discusses why Dell ThinOS ran a network diagnostic and why it failed.
This article applies to
This article does not apply to
This article is not tied to any specific product.
Not all product versions are identified in this article.
Symptoms
Affected Platforms:
- OptiPlex 3000 Thin Client
- Wyse 5070 Thin Client
- Wyse 5470 mobile Thin Client
- Wyse 5470 All-in-One Thin Client
- Wyse 3040 Thin Client
- Latitude 3420
- Latitude 3440
- Latitude 5440
- OptiPlex 5400 All-in-One
- OptiPlex 7410 All-in-One
Affected Operating Systems:
- Dell ThinOS
After a failed connection attempt, ThinOS 9 customers may raise a security concern when ThinOS performs a network diagnostic function that attempts to connect to an external public server. The same condition can be triggered when using ThinOS integrated Network diagnostic tools (Troubleshoot > Network > Diagnose).
Customers detected this condition when their internal Firewall software reports client communication attempts to IP 47.100.193.85 or dell1.com when an NTP server is not reachable from the thin client, or when the customer runs a local ThinOS network diagnostic test.
Cause
A hard coded URL value intended for www.dell.com was inadvertently defined as www.dell1.com.
Note: While a connection to an external public server was made, no data was written to the client that would compromise security or alter ThinOS client behavior.
Resolution
- ThinOS 2306 was released in June 2023 and has addressed this issue.
- ThinOS 2308 is scheduled to release in August 2023, updates below:
- Removed other network diagnostic logic in code; kept only network diagnostic logic in Troubleshooting where the user manually triggers the diagnostic.
- In Troubleshooting > Network > Diagnostic
- The web access testing is also removed (which required an external URL, for example, www.dell.com)
- Kept the
PINGandDNSresolve steps, added message that the user must click Continue- Previously, the user had to click Diagnostics
- Now, the user must click Diagnostics and Continue

Affected Products
Latitude 3420, Latitude 3440, Latitude 5440, OptiPlex 3000 Thin Client, OptiPlex 5400 All-In-One, OptiPlex All-In-One 7410, Wyse 3040 Thin Client, Wyse 5070 Thin Client, Wyse 5470 All-In-One, Wyse 5470, Dell ThinOSArticle Properties
Article Number: 000217192
Article Type: Solution
Last Modified: 24 Apr 2025
Version: 3
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