Dell ThinOS 9 выполняет диагностику сети после неудачной попытки подключения

Summary: В этой статье описывается, почему Dell ThinOS выполнила диагностику сети и почему она завершилась сбоем.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Затронутые платформы:

  • Тонкий клиент OptiPlex 3000
  • Тонкий клиент Wyse 5070
  • Мобильный тонкий клиент Wyse 5470
  • Тонкий клиент-моноблок Wyse 5470
  • Тонкий клиент Wyse 3040
  • Latitude 3420
  • Latitude 3440
  • Latitude 5440
  • OptiPlex 5400 All-in-One
  • Моноблок OptiPlex 7410

Затронутые операционные системы:

  • Dell ThinOS

После неудачной попытки подключения пользователи ThinOS 9 могут вызвать обеспокоенность по поводу безопасности, когда ThinOS выполняет функцию диагностики сети, которая пытается подключиться к внешнему общедоступному серверу. Это же состояние может возникнуть при использовании интегрированных средств диагностики сети ThinOS (поиск и устранение неисправностей >сети >).

Заказчики обнаруживают эту ситуацию, когда их внутреннее программное обеспечение брандмауэра сообщает о попытках подключения клиента к IP-адресу 47.100.193.85 или dell1.com, когда сервер NTP недоступен с тонкого клиента или когда заказчик выполняет локальное сетевое диагностическое тестирование ThinOS.

Cause

Жестко закодированное значение URL-адреса , предназначенное для www.dell.com, было непреднамеренно определено как www.dell1.com.

Примечание. При подключении к внешнему общедоступному серверу на клиент не записывалось никаких данных, которые могли бы нарушить безопасность или изменить поведение клиента ThinOS.

Resolution

  • ThinOS 2306 была выпущена в июне 2023 г., и в ней устранена эта проблема.
  • Выпуск ThinOS 2308 запланирован на август 2023 г., обновления ниже:
    • Удалена другая логика диагностики сети в коде; сохранена только логика диагностики сети в разделе «Поиск и устранение неисправностей », когда пользователь вручную запускает диагностику.
    • При поиске и устранении > неисправностей диагностикисети>
      • Также удалено тестирование веб-доступа (для которого требовался внешний URL, например, www.dell.com)
      • Сохранил PING и DNS Устраните шаги, добавлено сообщение о том, что пользователь должен нажать кнопку Продолжить
        • Ранее пользователю нужно было нажать «Diagnostics»
        • Теперь пользователь должен нажать Diagnostics и Continue
          Сообщение об устранении неисправностей Пользователь должен нажать кнопку Продолжить

Affected Products

Latitude 3420, Latitude 3440, Latitude 5440, OptiPlex 3000 Thin Client, OptiPlex 5400 All-In-One, OptiPlex All-In-One 7410, Wyse 3040 Thin Client, Wyse 5070 Thin Client, Wyse 5470 All-In-One, Wyse 5470, Dell ThinOS
Article Properties
Article Number: 000217192
Article Type: Solution
Last Modified: 24 Apr 2025
Version:  3
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.