NetWorker: Eine fehlerhafte Indexdatei führt dazu, dass Backup- und Indexvorgänge nicht mehr reagieren.

Summary: In diesem Artikel werden clientspezifische Probleme beschrieben, die sich aus Problemen mit dem Index des Kunden ergeben, und wie sie behoben werden können.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

  • Die Kommunikation wurde getestet und es wurden keine Probleme bei der Socket-Erstellung oder -Authentifizierung gefunden.
  • Einfaches Dateisystem speichert, reagiert während des Vorgangs nicht mehr und fährt nicht fort. Die Meldung kann variieren.
  • Einfache Dateisystemspeicher mit dem Switch -n oder -S sind ohne Probleme erfolgreich.
  • Der nsrck-Vorgang reagiert nicht mehr für den Clientindex.
  • Das Speichern ist erfolgreich, nachdem die Indexierung mit dem Attribut "index path" der Clientressource umgeleitet wurde.

Cause

Problem, das als beschädigte v6journal_rec Datei, potenziell größere Dateisystem- oder Betriebssystemprobleme identifiziert wird. Diese Datei sollte nicht beibehalten werden, während sich der Index für den Client im Leerlauf befindet.

Resolution

Die folgenden Vorgänge sollten nur dann versucht werden, wenn auf den Clientindex nicht zugegriffen wird: Backup, Wiederherstellung oder Indexbackup oder Serverwartung (nsrim / nsrck).
  • Wenn Sie die Problemdatei löschen können, entfernen Sie sie und testen Sie: nsrck -L6 <client>
  • Wenn Sie die Datei nicht löschen können, aber den Ordner umbenennen oder verschieben können, benennen Sie den ursprünglichen Ordner in einen Pfad außerhalb des Indexverzeichnisses um und stellen Sie den letzten zweifelsfrei funktionierenden Index mithilfe des Clients nsrck -L7 -t "mm/dd/yyyyy" < wieder her.>
  • Wenn der ursprüngliche Ordner nicht verschoben werden kann:
  1. Verschieben Sie alle Dateien im aktuellen Index mit Ausnahme des Problems an einen neuen Speicherort mit robocopy /XF v6journal_rec
  2. Ändern Sie den "Indexpfad" des Clients in den neuen Speicherort. Der angegebene Pfad hängt den Clientnamenordner automatisch an und erwartet ihn dort. Beispiel: Der Clientindex "archimedes" wird standardmäßig index\archimedes verwendet.
  3. Kopieren/verschieben Sie den Ordner "archimedes" in "index\temp\archimedes" und ändern Sie den Indexpfad des archivierten Clients in "(Path to nsr)\index\temp".

Ein Neustart des Betriebssystems kann helfen, die Problemdatei zu entfernen. Wenn das Problem beim Entfernen weiterhin besteht, wenden Sie sich an den Support des Betriebssystemanbieters, um Unterstützung zu erhalten. Sobald der ursprüngliche Ordner mit der Problemdatei verschoben oder entfernt werden kann, kann der temporäre Index wieder in den ursprünglichen Pfad verschoben und das Feld "Indexpfad" gelöscht werden.

Affected Products

NetWorker
Article Properties
Article Number: 000219840
Article Type: Solution
Last Modified: 07 Dec 2023
Version:  1
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