NetWorker: Nieprawidłowo sformowany plik indeksu powoduje, że operacja tworzenia kopii zapasowych i indeksu przestaje reagować
Summary: W tym artykule opisano problemy specyficzne dla klienta wynikające z problemów z indeksem klienta oraz sposoby ich rozwiązywania.
This article applies to
This article does not apply to
This article is not tied to any specific product.
Not all product versions are identified in this article.
Symptoms
- Przetestowano komunikację i nie znaleziono problemów z tworzeniem gniazda lub uwierzytelnianiem.
- Basic file system saves stop responding during operation and do not proceed; komunikat może się różnić.
- Podstawowy system plików zapisuje się przy użyciu przełącznika -n lub -S , który zakończy się powodzeniem bez problemu.
- Operacja nsrck przestaje reagować na indeks klienta.
- Zapisz pomyślnie po przekierowaniu indeksowania przy użyciu atrybutu "ścieżka indeksu" zasobu klienta.
Cause
Problem zidentyfikowany jako uszkodzony plik v6journal_rec, potencjalnie szerszy system plików lub problemy z systemem operacyjnym. Ten plik nie powinien być zachowywany, gdy indeks klienta jest bezczynny.
Resolution
Następujące operacje należy wykonać tylko wtedy, gdy nie jest dostępny indeks klienta: tworzenie kopii zapasowych, odzyskiwanie lub indeks zapasowy lub konserwacja serwera (nsrim / nsrck).
- Jeśli możesz usunąć plik problemu, usuń go i sprawdź: klient nsrck -L6 <>
- Jeśli nie możesz usunąć pliku, ale możesz zmienić nazwę lub przenieść folder, zmień nazwę oryginalnego folderu na ścieżkę poza katalogiem indeksu i odzyskaj ostatni znany dobry indeks przy użyciu klienta: nsrck -L7 -t "mm/dd/yyyy" <>
- Jeśli nie można przenieść oryginalnego folderu:
- Przenieś wszystkie pliki w bieżącym indeksie z wyjątkiem jednego problemu do nowej lokalizacji za pomocą robocopy /XF v6journal_rec
- Zmień "ścieżkę indeksu" klienta na nową lokalizację. Podana ścieżka automatycznie doda folder nazwy klienta i będzie oczekiwać go w tym miejscu; na przykład, domyślne wartości indeksu "archimedes" klienta to index\archimedes
- Skopiuj/przenieś folder archimedes do folderu index\temp\archimedes i zmień ścieżkę indeksu klienta archimedes na "(ścieżka do nsr)\index\temp"
Ponowne uruchomienie systemu operacyjnego może pomóc w usunięciu pliku problemu. Jeśli problem z usuwaniem będzie się powtarzał, skontaktuj się z działem pomocy technicznej producenta systemu operacyjnego, aby uzyskać pomoc. Po przeniesieniu lub usunięciu oryginalnego folderu z plikiem problemu, tymczasowy indeks można przenieść z powrotem do oryginalnej ścieżki, a pole ścieżki indeksu wyczyścić.
Affected Products
NetWorkerArticle Properties
Article Number: 000219840
Article Type: Solution
Last Modified: 07 Dec 2023
Version: 1
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.