NetWorker: Un archivo de índice malformado hace que el respaldo y la operación del índice dejen de responder

Summary: En este artículo, se describen los problemas específicos del cliente que surgen de problemas con el índice de ese cliente y cómo resolverlos.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

  • Las comunicaciones se probaron y no se encontraron problemas con la creación o autenticación de sockets.
  • Los guardados básicos del sistema de archivos dejan de responder durante la operación y no continúan; el mensaje puede variar.
  • Los guardados básicos del sistema de archivos mediante el switch -n o -S se realizan correctamente sin problemas.
  • La operación nsrck deja de responder para el índice del cliente.
  • El guardado se realiza correctamente después de redirigir la indexación mediante el atributo "index path" del recurso del cliente.

Cause

Problema identificado como un archivo v6journal_rec dañado, problemas potencialmente más amplios del sistema de archivos o del sistema operativo. Este archivo no debe persistir mientras el índice del cliente está inactivo.

Resolution

Las siguientes operaciones solo se deben intentar cuando no se accede al índice del cliente: respaldo, recuperación o respaldo de índice o mantenimiento del servidor (nsrim / nsrck).
  • Si puede eliminar el archivo con problemas, elimínelo y pruebe: nsrck -L6 <client>
  • Si no puede eliminar el archivo, pero puede cambiar el nombre de la carpeta o moverla, cambie el nombre de la carpeta original a una ruta fuera del directorio del índice y recupere el último índice en buen estado mediante el cliente nsrck -L7 -t "mm/dd/aaaa" <>
  • Si no se puede mover la carpeta original:
  1. Transfiera todos los archivos del índice actual, excepto el problema uno, a una nueva ubicación mediante robocopy /XF v6journal_rec
  2. Cambie la "ruta de índice" del cliente a la nueva ubicación. La ruta proporcionada anexará automáticamente la carpeta de nombres del cliente y la esperará allí; por ejemplo, el índice de "archivados" del cliente se configura de manera predeterminada en index\archimedes
  3. Copie o mueva la carpeta de archivos a index\temp\archimedes y cambie la ruta de índice del cliente de archivos a "(path to nsr)\index\temp"

Reiniciar el sistema operativo puede ayudar a eliminar el archivo con problemas. Si el problema de eliminación persiste, comuníquese con el soporte del proveedor del sistema operativo para obtener ayuda. Una vez que la carpeta original con el archivo con problema se puede mover o eliminar, el índice temporal se puede volver a mover a la ruta original y el campo de ruta de índice se puede borrar.

Affected Products

NetWorker
Article Properties
Article Number: 000219840
Article Type: Solution
Last Modified: 07 Dec 2023
Version:  1
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.