NetWorker: A malformed index file causes backup and index operation stop responding

Summary: This article describes client-specific problems arising from issues with that client's index, and how to resolve them.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

  • Communications tested and no issues found with socket creation or authentication.
  • Basic file system saves stop responding during operation and do not proceed; message may vary.
  • Basic file system saves using -n or -S switch succeeds without issue.
  • nsrck operation stops responding for client index.
  • Save succeeds after redirecting indexing using "index path" attribute of client resource.

Cause

Problem identified as a corrupt v6journal_rec file, potentially wider file system or operating system issues. This file should not persist while the index for the client is idle.

Resolution

The following operations should only be attempted when the client index is not being accessed: backup, recover, or index backup or server maintenance (nsrim / nsrck).
  • If you can delete the problem file, remove it and test: nsrck -L6 <client>
  • If you cannot delete the file but can rename or move the folder, rename the original folder to a path outside the index directory, and recover the last known good index using: nsrck -L7 -t "mm/dd/yyyy" <client>
  • If the original folder cannot be moved:
  1. Move all files in the current index except the problem one to a new location using robocopy /XF v6journal_rec
  2. Change the client "index path" to the new location. The path provided will append the client name folder automatically, and expect it there; for example, the client 'archimedes' index defaults to index\archimedes
  3. Copy / move archimedes folder to index\temp\archimedes, and change the index path of archimedes client to "(path to nsr)\index\temp"

Rebooting the operating system may help to remove the problem file. If the removal problem persists, contact the operating system vendor support for assistance. Once the original folder with the problem file can be moved or removed, the temporary index can be moved back to the original path, and the index path field cleared.

Affected Products

NetWorker
Article Properties
Article Number: 000219840
Article Type: Solution
Last Modified: 07 Dec 2023
Version:  1
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