Secure Connect Gateway: TechDirect Integration Removal

Summary: TechDirect account integration is being discontinued in Secure Connect Gateway (SCG) version 5.28.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

  • The TechDirect account integration feature is discontinued from Secure Connect Gateway v5.28.
    • The "TechDirect Replacement parts shipping for PowerEdge" section is removed from Settings > Preferred contact details in the SCG WebUI.
    • Shipping details are obtained from the asset's Location ID. See this Upcoming Enhancement Announcement for more information about Location ID.
  • The TechDirect account integration feature in SCG v5.26 and earlier stops working or displays a Connection not found! error message after June 2025.
Example:

Connection not found message

Cause

The TechDirect account integration feature in Secure Connect Gateway is being deprecated in SCG v5.28. This change streamlines the handling of call-home alerts from the products listed below to match the flow used for Dell High End Storage (HES), Converged-HyperConverged Infrastructure, and Data Protection products. This change benefits customers by having a unified call-home and case creation process common across all products.

The integration of TechDirect with Secure Connect Gateway was available for the following devices:
  • Server-Hypervisor
  • iDRAC
  • Chassis
  • Fluid File System (Fluid FS)
  • Dell Networking
  • PeerStorage(PS)-EqualLogic
  • Storage Center(SC)-Compellent
  • PowerVault (MD3 and ME4 Series)
  • Software
  • Virtual Machine
  • Webscale
  • Dell ML3
  • Direct Liquid Cooling
In the unified flow, alerts sent to the Dell backend by SCG are analyzed by the Dell Smart Policy Platform (SPP) which uses a rules engine to determine case disposition. SPP opens a Service Request (SR) if appropriate, appends subsequent call-homes to an existing SR open for the same issue, or filter events deemed not impactful or relevant. SPP can also examine parts replacement data included with an alert to aid replacement part work orders.

This change causes auto-forward (to TechDirect) to be set to off. TechDirect customers with auto-forward already set to off do not experience any changes in the call-home process. Customers with auto-forward on no longer have to look in the TechDirect portal to manually evaluate and send cases to support. Cases (SR) created by SPP cannot be viewed in TechDirect, however they can be seen in Dell online support and the MyService360 portal.

Note: The backend authentication scheme that supports SCG's TechDirect integration feature is also being decommissioned in July 2025. Customers who do not upgrade to SCG v5.28 by this time, receives a Connection not found! error when clicking Sign-in to TechDirect within SCG. All call-home alert handling is moved to SPP in June regardless of the auto-forward setting, to ensure that alerts are monitored.

Resolution

Upgrade to Secure Connect Gateway version v5.28 or later.

When an SCG with TechDirect account integration is upgraded to SCG v5.28 or later, the TechDirect account integration is automatically removed.

Affected Products

Secure Connect Gateway, Secure Connect Gateway - Application Edition, Secure Connect Gateway - Virtual Edition
Article Properties
Article Number: 000281820
Article Type: Solution
Last Modified: 27 Feb 2025
Version:  3
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