Dell P2222H Monitor Has No Video When Connected to a Dock Through HDMI or DisplayPort

Summary: This article provides information about the no video issue seen with a Dell P2222H monitor when connected to a dock using HDMI or DisplayPort.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Dell P2222H monitor may have no video when it is connected to a Dell Dock WD19 using HDMI or DisplayPort, and the dock is connected to the computer using USB-C. A message indicating that no DisplayPort cable is connected may show if the monitor has a DisplayPort cable connected to it but not to the computer. The external monitor does not display, but the computer detects the monitor model information.

Affected Monitor:

  • Dell P2222H

Affected Dock:

  • Dell Dock WD19

Affected Platforms:

  • Latitude 5340
  • Latitude 5350
  • Latitude 5540
  • Latitude 5550
  • Latitude 7340

Cause

This is due to the firmware issue of the USB-C Power Delivery controller Integrated Circuit.

Resolution

Refer to the following table and update the latest BIOS to resolve the issue. To download and install the BIOS, reference the BIOS Update Guide.

Platform BIOS version Release Date
Latitude 5340 1.21.0 or later Available
Latitude 5350 1.13.0 or later Available
Latitude 5540 1.21.0 or later Available
Latitude 5550 1.14.0 or later Available
Latitude 7340 1.22.0 or later Available

 

Affected Products

Dell P2222H, Dell Dock WD19, Latitude 5340, Latitude 5350, Latitude 7340, Latitude 5540, Latitude 5550
Article Properties
Article Number: 000306518
Article Type: Solution
Last Modified: 13 Nov 2025
Version:  3
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