Azure Virtual Desktop Client Stops Responding During Teams Calls in Dell ThinOS 9

Summary: This article provides more information about the Azure virtual desktop (AVD) client stops responding during a Microsoft Teams calls when using webcam or screen share in Dell ThinOS 9.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Affected Platforms:

  • Wyse 5070
  • Wyse 5470
  • OptiPlex 3000 Thin Client

Affected Operating Systems:

  • Dell ThinOS 9

Steps to recreate:

  1. Join a Teams call or meeting on Thin Client running AVD client v2.3.3078 and ThinOS 9 2505.
  2. Someone in the meeting starts their video from a webcam or shares their screen.
  3. After a few seconds, the AVD client crashes, and the AVD session to the VDI disconnects.
  4. Download the logs bundle from the Thin Client and extract it in a folder on a computer. Checking the messages log file in [logs folder]\compat\linux\var\log, you may see an error similar to the following:
    Jun 20 09:45:54 IT13993 kernel: [442.266127] pid 4731 (avd), jid 0, uid 1001: exited on signal 6 (no core dump - bad address)
  5. Checking the wlogd.log in [logs folder]\compat\linux\var\log\wlogd, you may see an error similar to the following:
    [2025-06-20 09:45:53.981] E/avd            /DUMP            (4731/35655) avd crashed
    …
    [2025-06-20 09:45:54.065] N/WebUIProc/WebUIModule (0/0) [RDP] disconnect "Standard Desktop"
    
  6. The issue is only produced in incoming video or screen share.

Cause

An unhandled assertion check failure in the H.264 video decoding process is the cause of the disconnection. The failure occurs when the H.264 decoder encounters issues with reference picture handling and Supplemental Enhancement Information (SEI) data.

Resolution

Dell engineering is aware of this issue, and a fix will be released with the new AVD package for ThinOS 2508.

Workaround:

Downgrade the AVD package to:

  • Microsoft AVD package v3.1.3044
    Or,
  • Microsoft AVD package v3.0.2442
To downgrade the AVD package:
  1. Download the package from the Drivers & Downloads section of the product page of the Thin Client that is needed:
    • ThinOS 2411 (9.5.4070) Microsoft AVD package v3.0.2442
    • ThinOS 2502 (9.6.1080) Microsoft AVD package v3.1.3044
  2. Follow the steps in the Dell ThinOS 9.x 2505 Administrator’s Guide to upload the package to the WMS console and to assign to the affected devices using Policy.

Additional Information

Learn more about how to capture ThinOS logs using Wyse Management Suite from the section Troubleshooting your thin client > Request a log file using Wyse Management Suite of the Dell ThinOS 9.x 2502 Administrator’s Guide.

Learn how to push the AVD package on the affected devices following the section Upgrading the ThinOS firmware > Download ThinOS firmware, BIOS, and application packages > Upload and push ThinOS 9.x application packages using Groups and Configs on Wyse Management Suite of the Dell ThinOS 9.x 2505 Administrator’s Guide.

Learn more about how to capture logs on ThinOS 9.x in the Troubleshooting your thin client section of the Dell ThinOS 9.x 2505 Administrator’s Guide.

Affected Products

OptiPlex 3000 Thin Client, Wyse 5070 Thin Client, Wyse 5470
Article Properties
Article Number: 000340003
Article Type: Solution
Last Modified: 22 Sep 2025
Version:  2
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