PowerFlex 4.x SupportAssist state shows: error when configuring a Remote Access service

Summary: SupportAssist stops working, state shows: error when configuring a Remote Access service

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

SupportAssist stops sending call home files and alerts to CloudIQ.After checking the pod status with the following command:

kubectl get supportassist -n powerflex -o yaml

It shows the following status:

lastUpdated: "2025-01-13T09:05:33Z"
    phase: 'Reconciling: Remote access configuration failed'
    remoteAccessIP: 
    serialNumber: ELMVXFxxxxxxxx
    state: Failed
    statusMessage: 'error when configuring Remote Access service : '   <<<<<

supportassist-vxflexappliance_logs shows an ERROR:

169 2025-01-30 08:22:27,134 CP Server Thread-10 DEBUG DellESE.ese.security.lockboxclient.lockboxcrud LN: 99 -31 : The requested Lockbox entry could not be found.For key:ESE_client_passphrase hence returning None! 
169 2025-01-30 08:22:27,134 CP Server Thread-10 ERROR DellESE.ese.rest.urllib_client LN: 293 Missing passphrase in Secure Store (or plug-in not found). Unable to load client certs.   <<<<<

supportassist-vxflexappliance_logs also shows SupportAssist failing to connect to https://esrs3-core.emc.com/:

169 2025-01-30 08:22:47,186 CP Server Thread-10 DEBUG DellESE.ese.srs.srswebapi LN: 85 Failed connectivity to https://esrs3-core.emc.com: err 4:timeout error   <<<<<
169 2025-01-30 08:22:47,186 CP Server Thread-10 DEBUG DellESE.database.esedb LN: 17 Save connectivity result: status=TimedOut, HTTP code=None, time=1738225367, url=https://esrs3-core.emc.com

Also, an ERROR regarding ESE not being initialized:

169 2025-01-30 08:22:48,499 Config Minder ERROR ESE.ConfigMinder LN: 150 configminder thread - ESE is not initialized

 

Impact 

CloudIQ and hardware/software alerts are no longer being sent home.

Cause

A network-related issue between the SupportAssist pod and the Dell Secure Remote Services server (esrs3-core.emc.com) causes a remote access configuration error on the SupportAssist pod.

 

Resolution

Confirm network connectivity between the SupportAssist pod and the Dell Secure Remote Services server, by running a dig command from inside the pod:

 kubectl exec -it -n powerflex supportassist-vxrackflex-0 – bash
 
# dig esrs3-core.emc.com

Deregister and reregister SupportAssist with a new access key.

An improvement for recovering from network instability or loss was introduced in PFMP version 4.8.

Impacted Versions
PFMP 4.x

Fixed In Version
PFMP 4.8

Affected Products

PowerFlex rack, VxFlex Ready Nodes, PowerFlex custom node, PowerFlex appliance R650, PowerFlex appliance R6525, PowerFlex appliance R660, PowerFlex appliance R6625, Powerflex appliance R750, PowerFlex appliance R760, PowerFlex appliance R7625 , PowerFlex appliance R640, PowerFlex appliance R740XD, PowerFlex appliance R7525, PowerFlex appliance R840 ...
Article Properties
Article Number: 000307523
Article Type: Solution
Last Modified: 30 May 2025
Version:  2
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