VxRail: Node Health-checks Fail with Message iDRAC queries failed

Summary: VxRail node health-checks query the iDRAC using vmk1 using Redfish or the Platform Service. If one of the services that maintains this communication channel is down, the iDRAC queries can fail. ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

VxVerify runs tests on each node by uploading a 'minion' heath-check program, to detect issues that may cause upgrades to fail. Node health-checks such as 'idc_q', 'idc_swi' and 'idc_as' query the iDRAC using remotecmd racadm using vmk1.
 
Test Result
Result code
    Result Interpretation
Pass
0
iDRAC commands ran successfully.
Warning
1
See each iDRAC health-check for warning conditions
Failure 2 iDRAC queries failed
Critical 3
This test has no critical result.

If the iDRAC commands timeout or get an invalid response, then other iDRAC based tests are likely to fail too (idc_xxx).
An example of the health-check output, when iDRAC is not responding, is shown below:
#========================#======#=========#====================================================================#==============#
|  Hostname / Category   |Status  Dell_KB |  Warnings or Failures, unless tests Passed                         ; Product S.N. |
#========================#======#=========#====================================================================#==============#
| Node1                  | Failure  43184 | idc_q: iDRAC queries failed                                                      .|

Cause

The health-checks issue commands on the ESXi to iDRAC using the iDRAC vmk (usually vmk1), with commands such as the following:
/opt/vxrail/bin/remotecmd -q -i /etc/ssh/ssh_host_rsa_key -l vxpsvc 169.254.0.1 racadm swinventory
 
For the above to work the internal connection between ESXi and iDRAC must be running, which depends on the iSM service (dcism or dellism).
If iDRAC based tests are reporting 'iDRAC queries failed', then it may be the communication channel to the iDRAC that failed, rather than an iDRAC failure.

Resolution

The first step for 'iDRAC queries failed' events, would be to check the iDRAC UI, to make sure that is working correctly.
If the User Interface (UI) to iDRAC is responding correctly, then the issue may be in the connection to iDRAC from ESXi. This communication channel uses VMK1 and is maintained by the iDRAC Service Module service (ISM).
One method to correct this would be to force an iDRAC and iSM services restart using VxVerify:
./vxverify.sh -a ism_fix=Node1


Refer to article 205179: health-check 'ism_fix' attempting to automatically correct Dell iSM issues

Affected Products

VxRail, iDRAC Service Module, VxRail Appliance Family, VxRail Appliance Series, VxRail Software
Article Properties
Article Number: 000205769
Article Type: Solution
Last Modified: 25 Aug 2025
Version:  5
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.